[BUG-10417] Trial mode ended but countdown frozen and can't reset

I’m currently developing in trial mode, and my two hours were up, so everything has gone “bad quality - trial expired”. I opened the gateway in the browser to reset it, but the trial mode countdown is stuck at 1:55:18 and no longer counting down, and there’s no button to reset it. I have tried restarting the PC and the Ignition Gateway service, but it’s still the same.

Any ideas on what else I could try?

Hi ASF

I am sorry to hear that you are having problems with igniton 8 in trial mode. Well one thing
I would suggest is just creating a gateway backup of your existing project and uninstalling and re-installing ignition again and seeing if you are able to get it work correctly.

Thanks
Anthony

I have tried uninstalling and reinstalled the latest nightly build - same symptoms, countdown perpetually staying at 1:55:18 with no means of resetting.

In case it’s relevant, I didn’t have to restore my backup once I reinstalled, the gateway configuration and project were all still intact.

Try uninstalling and wiping the directories before re-installing. Then if it works on a bare, new install, do the restore and see if it kills it.

Which directories do I need to wipe? I tried again, and deleted C:\Program Files\Inductive Automation (or at least, moved it to the desktop) before reinstalling - same result.

Hmmm. I don’t know of any other.

This is very strange. Can you try in a private/incognito window, or try deleting any browser caches?

1 Like

Thanks, both of those worked. Just for information, I also tried using a different browser (edge) before I cleared the cache - that did not work.

Just FYI, this happened again today - stuck at 1:59:33. Same resolution so no harm done - but the fact that it’s happened twice is a little concerning. Currently running b2019030302, but the first time it happened I was on an earlier one from mid Feb.

This happened again today, after the PC crashed and rebooted itself. This may have been the case in each instance (I don’t always notice it happening until the trial time expires and I go to try and reset, so I can’t say for sure one way or the other).

I have a wireless hotspot that I’m using to test the app on an iPad, and I’m charging it from the PC. About 50% of the time I plug it in to charge, the PC crashes. Strange, annoying, and not at all a problem for this forum - but the upshot of that is that there have been several of these sort of BSOD crashes while I’ve been developing, and its entirely possible that such a crash preceded each instance of the countdown freeze.

I’ve now gotten to a place where it’s permanently broken, and clearing browser caches has no effect. Private windows still work to reset, but as soon as I go back to a regular window, it’s stuck at the same place.

I have just received a license certificate, so I can make the problem go away whenever by activating my license - but I’ll hold off for a short time in case anyone wants to try and track the cause down a little further, now that it’s permanently “broken” and therefore (presumably) easier to find the cause.

There is an internal ticket for this, it was originally found in version 7.9 and hasn’t been seen much internally since. I’ll link it to this forum post, but considering it’s an older bug we may not get to it soon. If it helps, when this was last seen another workaround was found. In your browser, if you open the inspection tools and go to the Network tab, there is a checkbox labeled Disable cache that should stop the banner from being stuck as long as it is enabled and the inspection tools are open.

1 Like

No problems, yes, that workaround works too. As I have a license ready to go it’s not a problem, just thought I’d hold off in case it was helpful for you tracking down the root cause. But it looks like you’re already on top of it :slight_smile:

I got the same issue with Version: 8.0.5 (b2019101516).
Trial is ended and countdown frozen.

I will uninstall and install Ignition again.
I hope this will fix the issue.

Thanks

Finaly, it’s a browser issue. Frozen on FireFox but not on Microsoft Edge.

Hey mate, exactly the same thing happened to me too with Version 8.0.14 (b2020062220).

Are you guys looking into this?

An info that might point you to a direction is that I’m using FireFox. Cheers!