[Bug-1106] Force Secure Redirect used when SSL is not enabled

With SSL enabled (via a CA-signed certificate) and the “Force Secure Redirect” option checked, I took a gateway backup and restored it on another gateway, which was missing the certificate. Ignition correctly identified that SSL was no longer configured and grayed out the HTTPS Settings pane. However, despite being disabled, the “Force Secure Redirect” checkbox was still checked, and Ignition would not allow me to connect via the Designer over the HTTP port.

The workaround was to enable the checkbox using Chrome DevTools, uncheck it, and click the Save button. A proposed fix would be to ignore the “Force Secure Redirect” setting if SSL is not configured.

Bug confirmed in 8.1.5 running on Linux.

1 Like

Thanks for sharing the issue. This sounds like the same issue reported here: [BUG-1106] Web Server SSL Config Issue

We have the bug tracked in our internal ticket system and will reply back once the issue is fixed.

Oops, looks like a dupe on my part. Glad you have this already accounted for. Thanks for the update!

1 Like