[Bug-11134] Unable to save project

I just installed ignition 8 beta. It tells me that there is an error when saving my projects with the gateway.

For some reason I run gcu.exe and it does not start.

C: \ Program Files \ Inductive Automation \ Ignition

I have already uninstalled several times and installed again.

I do not know what else can happen.

1 Like
  1. The GCU is probably going to be removed, except as a command-line utility. There’s nothing in the GCU that can’t be accomplished in other ways. What were you trying to do?
  2. I’m not sure what “It tells me that there is an error when saving my projects with the gateway.” means. Please be more descriptive.
1 Like

First thing I would do is make sure you don’t have faulted modules. Beyond that, we’ll need more information.

Also, please follow the format of the post/title as described. We can’t help if we are not able to understand/replicate the problem.

3 Likes

4 posts were split to a new topic: [Feedback] Graphical GCU removed in 8.0

I removed all module from version 7.9 and the error is gone.
I thought that i can reset the Gateway the error will go away.
Anyway the problem is solved.
Thanks for your support.

*I am looking now for videos of how to use prespective. Looks very interesting.

I have more information about the problem the error only appears when in perspective mode i try to fit a picture. When click on save and publish. The error appears at:

“Error reading updated project from Gateway”

I don’t know what to do.

On the error dialog, can you go to ‘Full’ and copy the entire stack trace of the error? Then post it here, inside three backticks:

```
paste the error here
```

com.inductiveautomation.ignition.client.gateway_interface.GatewayException: Error writing to server
at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.newGatewayException(GatewayInterface.java:338)
at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.getResponse(GatewayInterface.java:498)
at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.sendMessage(GatewayInterface.java:270)
at com.inductiveautomation.ignition.designer.gateway.PriviledgedDesignerTask$GatewayMessageTask.execute(PriviledgedDesignerTask.java:440)
at com.inductiveautomation.ignition.designer.gateway.PriviledgedDesignerTask$TaskThread.run(PriviledgedDesignerTask.java:328)
at java.base/java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: Error writing to server
at java.base/sun.net.www.protocol.http.HttpURLConnection.writeRequests(Unknown Source)
at java.base/sun.net.www.protocol.http.HttpURLConnection.writeRequests(Unknown Source)
at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at java.base/java.net.HttpURLConnection.getResponseCode(Unknown Source)
at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.getResponse(GatewayInterface.java:418)
… 4 more

Ignition v8.0.0-beta0 (b2018110513)
Java: Azul Systems, Inc. 11.0.1

This is a documented issue when trying to save a large view in Perspective. Pictures cause this to happen really easily if you are inserting the picture by dragging from your desktop to the view.

A nice workaround for this is to go to Tools > Image Management and upload the picture you want. Right click the picture once it’s uploaded to image management and select “Copy Path”. Then on the Perspective view, place an Image component and set the source to /system/images/{path you coped}. That should allow you to save with the image until we fix the problem.

2 Likes

Hi Oscar,

We’ve made some changes that should help with the issue you are seeing. Please let us know if you continue to see this behavior after upgrading to the latest build.

Thank you!