[Bug-11336] Nudging in Perspective

I’m trying out Perspective and wanted to nudge a component around. Doing so with the arrow keys has very unexpected effects.
Up arrow: Nudges 1 px to the right
Right arrow: Nudges 2 px to the right, 1 down
Down arrow: Nudges 1 px to the right, 2 down
Left arrow: Nudges 1 px down

Using the shift key as a modifier has the effect of both nudging and changing the size of the component.

Also, if I click in the Project Browser to select a component vs. clicking the component itself, it’s difficult to tell if the Project Browser has focus (where up/down moves the selection cursor up and down one item) or if the component itself has focus where up/down will hopefully nudge the component.

This is with the latest nightly build.

This is a bug that we encountered a very long time ago and thought we had resolved. I’m not able to replicate it in my Designer, so could you provide some specifics about your environment?

Windows 7, 64 bit. The status page reads version 8.0.0-beta0 (b2018113002). Obviously, everything is running in trial mode. I installed the nightly build over my existing build this afternoon.

I was finally able to replicate this issue by tinkering with the zoom levels of the Designer. I’ve re-opened our original ticket and updated it with the replication steps. Thank you for bringing this to our attention once again.

As a workaround, I did not notice any abnormal behavior while my Designer was at the 100% zoom level.

This does happen for me at the 100% zoom level and all the other zoom levels I tried. (I didn’t realize zooming was an option before). After fiddling with the zoom levels a bit and returning to 100%, it’s still happening, but the nudge distances are different and non-integer amounts.

Starting at (10,10), the right arrow moves my component to (14.9960289, 13.9960289).

Do you happen to have scaling enabled? The “root cause” is a failure to adjust for viewport manipulation. In my testing environment I believe I was able to remove the unwanted adjustments by making sure scaling was off and zoom was at 100%. A warning though: using the Designer without scaling and no zoom can be difficult in some environments - especially those with large monitors.

Where is scaling set? I don’t see any option or property with that name. The root (view?) and coordinate container are all mode: fixed.

Ah, sorry, scaling is an OS property.

Directions on how to change scaling on Windows 7 (supposedly):

  1. Click the Start button
  2. Type Display in the Search box
  3. Choose Display in the Control Panel section of the results
  4. Select the 100% option

Scaling is set to 100%.

We tried to replicate this with a Windows 7 VM set to have no scaling, with 100% zoom, but even after trying a regular Coordinate Container and a Coordinate Container set to use percent mode, we’re still not able to replicate your behavior.

Would you consider posting your View here?

  1. Hold down ‘Shift’, then Right-click the View node (the node you gave a name to, not the root node).
  2. Select Copy JSON.
  3. Paste the contents of your clipboard into your preferred text editor.
  4. Save the file as a .json file.
  5. Upload the file in a post.

Attached. At this point, I do hope it is a bug and not some obvious property I haven’t set correctly.

SR.json (4.0 KB)

Ah, there’s the issue. Borders are currently behaving in a manner other than we would like. The current workaround for this is to remove the border on your Container, perform your adjustments, and then replace the border. I’ll update our internal ticket to reflect that someone else has encountered this besides myself.

1 Like

Not as obvious as you would think. The guys have provided a licence for us all to use for ignition 8 :slight_smile:

For further info, in case it’s helpful: I am also encountering this issue with the zoom level set to 100%, and it seems to be triggered whenever I select multiple objects and try to move them together. As soon as I do that, the nudge directions “break” for the container that those objects and can’t be recovered. Setting the border style to “none” as you suggested has worked - as soon as I put it back to solid, the behaviour returns. If I manage to avoid trying to move multiple objects at once, the container never seems to display the issue with or without a border.

Edit: I am also encountering it with labels that have a margin on one side, regardless of the border selection

This issue was fixed in the build that was uploaded on 3/9. Please let us know if you continue to see this behavior after upgrading.

A post was split to a new topic: [Bug-13329]Components With Margins Move During Resizing In Coordinate Containers

A post was merged into an existing topic: [Bug-13329]Components With Margins Move During Resizing In Coordinate Containers

This issue is happening on Ignition Edge, windows version 64, 8.1.12, Windows 10 Pro 19043.1348 with scaling set to 100%. When I zoom in on view in the designer the arrow keys do not function properly as indicated above.