[bug-11605,10666]7.9 to 8.0 Project Import Issues

My original 7.9 project did not import successfully to 8.0 I have not tried sense the 6th

Reference to the following post I have the same setup [BUG] Gateway Fails to Start

After the project hung up on starting screen for over an hour tried restarting the gateway which showed faulted and the following error.

The Ignition Gateway has failed to successfully start up.
Reason: java.lang.illegalArgumentException:java.io.IOException:
com.google.common.collect.ComputaionException:
com.inductiveautomation.ignition.common.tags.paths.parser.TagPathFormatException:
Token PROPERTY_SEPERATOR found after property name.
Check the logs for more details.

to get by this exported projects, tags configuration etc, and imported them individually into 8.0 11-9-18 nightly download windows 10

-One of my Data Type tags uses an expression to convert a coil and auxiliary feedback into an integer using the following formula in 7.9 and appears to have worked before
binEnc({[.]Blow_Stat} & {[.]RFan_Heat},{[.]Burn_Stat})
But requires the logical and in 8.0 to work correctly.
binEnc({[.]Blow_Stat} && {[.]RFan_Heat},{[.]Burn_Stat})
Is there a reason the logical && works but not the Bitwise & in this situation?

-There are also some 2 stage toggle buttons used throughout the project. These buttons are missing a border, and color animation that worked in 7.9 the text animation continues to work. The animation was based off a Boolean property passed into a Template from a Data type that I had built. The tag is a Boolean from a modicon PLC over Modbus, the tag is showing good quality and proper state in the designer and viewer for the text value only.

-Some buttons which are for page to page navigation are missing boarders that they had in 7.9

-Several sparkline charts show no data while others do. This is similar setup to above, with Sparkline referencing a property inside of a template to get the tag path using indirection from a Data type I built which has tag history on the Data type. Data is showing good on a numerical display, but graph only displays Hi/ Low ranges but no data

-Formatting a numerical display the following display features were no longer able to reference the prior path to the tag.
Tracing them out they were no longer under the available tag properties that a display can be bound to. This tag is a Data Type tag with an integer value.
tooltip
engUnit
formatString

Thanks,

Martin

Martin,

There isn’t a reason why it isn’t working at this point. An issue has been added and we will look into why this is happening.

We are aware of the issues with borders on buttons and are working to resolve these.

Is there anything distinctly different about the charts that show data and the ones that don’t? Based on what has been described, it seems like some of the Tag Paths can’t be found. I am curious how the tag paths are formatted for the items that aren’t displaying data. If you could provide a specific example, may help lead to understanding this issue.

If I understand this correctly, you are attempting to bind a component to one of the properties of a tag, but when you expand the tag the properties are missing. If this is the case, we do have a ticket to add the available properties back before release. Until then, you can manually define the binding to a tag tooltip, engUnit and formatString by manually adding the property to the tag path definition. Examples of this would be:
Assuming Tag Name is Example

  • ToolTip: Example.tooltip
  • EngUnit: Example.engUnit

If you need the name of a property that you are uncertain about, the property name can be looked up by right clicking a tag and opening the Raw Tag Editor Edit (raw).

If I misinterpreted the question, could you please define an example of the issue that might help me better understand what the issue is.

Thanks,
Garth

2 Likes

Thank you very much, That answers all of my questions at this time.

I found for the graphs, That I had set “Range High” and “Range Low” Set points, and My graphs had gone out of the range so they were no longer displaying.

Thanks,
Martin