[BUG-11618] Drawing component disappearing

I have a sort of ‘home’ view that is just a background color with a drawing component that came from me dragging an svg file into the view. In the session (loaded in my browser) if I go to another page and then back (via a menu tree item), it will be gone. Just the blank background color. If I click the same menu item again, it will reappear. In the designer, if I go into preview run it will disappear. Once I turn it back off and click in the view, it will reappear.

I tried with an in-house favorite .svg and had no issues. Does your Drawing component have any content? (check Drawing.props.elements - it should have multiple entries) If your Drawing doe shave content, please consider sharing your View so that I can diagnose the issue (hold shift and then right-click the named View node, select Copy JSON, and save the text on your clipboard as a .json file).

If your Drawing component is empty, then the reason it is disappearing is because it has nothing to display.

I’ve attached my View to this thread. Please open the .json file in a text editor, press Ctrl-A (or CMD-A) to select all of the text in the file, copy the text. Make a new View somewhere in your project , hold down shift and then right-click the new View’s node (not the root, but the View which you named) and then select Paste JSON

You’ll notice that I have an empty Drawing, an icon, a button, and my dropped-in .svg file (the tiger). The button is actually under the tiger .svg, but the button isn’t covered because that part of the .svg has nothing to impede vision to lower levels.

TabulaRasa.json (152.4 KB)

I know what’s going on now, just not why. Your view worked fine, so I started looking for what I changed from the default. I had the mode on root set to ‘percent’. Setting it to ‘fixed’ fixes this problem. Turning on percent mode in your example also breaks it. But, I would hope that isn’t the intended behavior of this mode. When the graphic DOES load, it looks how I want it to - centered in the middle of the screen.

Edit: I should mention this is the coordinate view, I imagine I could make it work how I want it to by using flex or something. Is there any way of changing the container mode easily in the works?

1 Like

Ah, I see the issue now - I was unaware you were in percent mode. This issue is a concern, and I’ve created an internal ticket for it. Thank you for bringing it to our attention.


This issue was fixed in the build that was uploaded on 11/20. Please let us know if you continue to see this behavior after upgrading.