[Bug-11950] system.tag.exists

This function is always returning True, no matter what is the inserted address.

Would you mind providing the script in which you’re making this call? I just tried on a build from Tuesday and I encountered no issue with the method.

if I simply try from script console:

system.tag.exists(“notexisting”)

I get True (of course that tag is not defined). Same thing in a gateway script.

Thank you

Interesting. I’ve opened an internal ticket to address the issue.

Did you encounter this anywhere else? My component scripts didn’t encounter the issue, but as soon as I tried the script console I did indeed encounter it.

This issue was fixed in the build that was uploaded on 12/14. Please let us know if you continue to see this behavior after upgrading.

Dears,
I am currently using the 8.0.3 release.
I notice that if I run the function system.tag.exists(’[notexisting]’) the result is True!
I mean the return value is always True if I search for a not existing Tag Provider.

Thanks.

Dears, any update on this topic?

There was some nuance in quality codes introduced in 8.0; I’ve just put in a fix that you should see in the nightlies soon, as well as the next release.

I am still seeing this issue on Ignition 8.0.14 when using a remote tag provider.