[Bug-12910]Some of my Perspective screens not loading past few patches

A few builds ago I started getting that weird error where it put a bunch of json code in the designer window and didn’t load the screen on some of my screens. So I stepped back from the project and waited for a patch to fix that.

I believe that issue was fixed in the 3/13 daily patch. I applied the patch and the views still wouldn’t load so I waited for today’s daily. It is still throwing errors.

Usually it simply says “error” in the place where it would normally display my designer version of the view I’m trying to edit.

I tried today’s daily to see if that fixed it. Now I’m getting this message every time I load the designer.

I tried deleting my client cache. I also googled that error and it said to delete some cache files from the google local files so I’m assuming Ignition has its own version of these files that I need to delete to make the first error stop happening and possibly fix all issues.

Sometimes I also get this error when I open one of the offending views.

I’m still learning where I need to poke to fix these kinds of problems. I’m not a web developer by trade so I need a little instruction so I can poke in the right places.

Let me know if you need any other information.

I think the 2nd error message is only occurring on yesterday’s daily build. I restored the backup to a station with today’s daily and it is running on another station that is running yesterday’s daily. I don’t get the error in that screenshot on today’s daily but it still isn’t loading my screen.

The first error might be unrelated to the issue at hand. There were some issues with a previous build and they had to roll back some changes. Not sure on the 2nd error. Seems like it would be the main error for what you describe.

Thanks. I did see that thread but forgot about it because I wasn’t experiencing that error when I read that thread and the thread didn’t really mean anything to me at the time.

So that error isn’t the cause of my issue.

Something else is causing my screens to not load anymore.

To my knowledge (verified) the profile error was caused by us introducing a new version of JXBrowser, which we then reverted (out of an abundance of caution) to the previous version because of unexpected issues while testing said newer version. This left artifacts in the Chromium profile which reference a newer version than is actually being used. The profile errors should be benign - they’re just annoying for a short while longer.

When it comes to the view being undefined, we would need to see the structure of the View in the File System. Could you screenshot the offending View’s directory from the Gateway (something like C:\Program Files\Inductive Automation\Ignition\data\ projects<project_name>\Views<project_dir_structure><view-name)? Does the offending View’s directory contain data.bin? view.json? Both? Neither?

Dennis Muilenburg over here :laughing:

1 Like

I have the view.json but no data.bin

The error messages aren’t bothering me but my views are loading in an active session or development. These views are loaded by other views in a heirarchy so basically any view that touches a toxic view is also toxic.

Oh hi Kevin :slight_smile: I met you when I went out for my Ignition training classes. I was the guy that said how I was really impressed with how much Ignition had improved since the early releases (if that rings a bell). I’m still impressed.

Have you encountered this elsewhere? I’m betting if you open that view.json, you’ll find that the contents are null. If that’s the case, there’s nothing we can do to recover the missing View; this is an issue that should be resolved going forward, but there’s no way to repair the corrupted files short of replacing them from a backup.

If you encounter this issue again we need to know.

I haven’t seen this bug occur again and we have done several daily updates since it did occur. I believe it’s fixed.