[BUG-13053] Issue using UDT Nesting

Dear all,
I am currently using the build b2019030402.
I created an UDT (in this example called F_U_DEOTrk) then I inserted it into another UDT (called F_U_DeoStage).


When I try to create a new tag, instance of this second UDT, everything seems to work well (all members are present within the structure):

but, when I apply and save this instance, the tag created does not contain the members present within the original UDT (see New Instance tag in the below image)


In the log there is the following message:

Attached, a copy of the two UDTs:

UdT F_U_DeoStage.txt (218 Bytes)
UdT F_U_DEOTrk.txt (216 Bytes)

Let me know for further information.

Thank you.


The error is indicating that the UDT the instance is based on has a circular dependency between itself and one of its members. Can you please post an export of the UDT DataType Definition for UDT_DeoBatchTool and any other UDTs that are included as members?

Also, it is easier than I would like to create a new UDT Instance within an existing DataType rather than as an independent tag. It would be a good idea to confirm that the UDT instance was created as its own tag and not within the UDT Definition.


Hi Garth,
I tried to start from the beginning; I created 3 different UDTs:

  • F_U_UDT1: simple UDT that contains only one OPC member
  • F_U_UDT2: UDT that contains 2 OPC members and an instance of F_U_UDT1
  • F_U_UDT3: UDT that contains 2 OPC members and 2 instances of F_U_UDT1 (with different names).

Then I tried to create tags:

  • Tag1: instance of F_U_UDT1
  • Tag2: instance of F_U_UDT2
  • Tag3: instance of F_U_UDT3

The first two tags are correct, the third contains only the name but has no members:

In the log there is the following message:

Attached, the export of the UDTs and tags:

UDTs.json (2.3 KB)
tags.json (850 Bytes)


Appreciate the help in figuring this out. The reason it is failing out is due to an error where a composite UDT containing more than one copy of a different UDT is triggering the circular dependency error (ex. F_U_UDT containing 2 members of F_U_UDT1). An internal issue has been logged.


Hey Garth, any update on this? It’s killing my development!

This issue was fixed in the build that was uploaded today (3/14).
Please let us know if you continue to see this behavior after upgrading.

Great! Thanks!

Confirming its working for me too.


Great, it works.
Many thanks.