[Bug-13083] UDT Parameters not retained through gateway restart

I have noticed that UDT parameters do not seem to be retained through a gateway restart for UDT Instances. Using b2019030702 currently but I noticed this on b2019030502 as well. Instead the UDT instances seem to revert back to the default value for the UDT.

I am attempting to duplicate this but I have not been successful. Would it be possible to list out the steps you are performing to see this issue occurring? Exporting the UDT definition would also be helpful. If there is a specific circumstance when it happens I want to narrow it down.

Things I have tried so far (all with a single UDT instance that contains every datatype we allow as members):

  1. UDT Instance with parameters (Default set as NULL) overridden
  2. UDT Instance with parameters (Defaults set as non NULL) overridden
  3. Some Parameters set, others left as default
  4. Number values for parameters
  5. String value for parameters
  6. Double value for parameters

Any help provided to assist in duplicating is greatly appreciated.


This UDT has 5 parameters all strings. There are 17 instances of the UDT with the same name but separated by folder. So instance 1 is PCSs/PCS 1/Inverter; instance 2 is PCSs/PCS 2/Inverter, etc. The UDT is attached. The only parameters that were changed between instances were ‘DC Name’ and ‘DeviceName’.

UDT.json (949.2 KB)

I am still unable to duplicate this issue. At this point I am thinking it might be related to how the tags were created. Can you elaborate on how the tags came to exist in the system? Were they:

  • Migrated on upgrade from an 7.x backup
  • Imported
  • Created with the Multi-Instance Wizard and moved
  • Manually Created by hand and copy/pasted/renamed


The UDT was imported from a 7.9 system. I created one tag in a folder and then copy/pasted the initial tag into the other folders.

After some more testing it appears that the UDT parameters are retained provided I right click on the tag and either change the parameters in the edit tag popup or the edit raw popup. What I was doing was clicking on the drop down for the parameters in the tag browser and typing the new parameter into the value column, when I do that the value is changed in the tag browser, and the change propagates through the UDT, but is not retained through a gateway shutdown.

Thank you for providing the reproduction steps. An internal ticket has been created for this issue.


Is there any update on when a fix for this could be expected?

The ticket has been prioritized, but an ETA on delivery isn’t available yet. We are currently attempting to finalize a release candidate and only mission critical issues are being worked on. This specific issue isn’t likely to make the 8.0.0 release based on its current priority, but a fix will likely come in the 8.0.1 release.


This issue was fixed in the build uploaded today (4/10).

Normally we have the nightly builds accessible via https://inductiveautomation.com/downloads/ignition, but in the meantime you can find it via this post:
8.0.1 Nightlies - Temporary Place to Download the Latest Builds

Let us know if you have any issues.