[BUG-13258] Swap projects UI

Dear all,
I am currently using the build b2019030402 .
I notice that when I swap between projects in the designer, the UI looks blocked and the following screen is displayed:

After a while the UI returns right and I am able to start using the designer.
In the Output Console, I receive the following message:

09:45:25.785 [AWT-EventQueue-0] INFO designer.main - Initializing Scripting…
09:45:25.801 [AWT-EventQueue-0] INFO designer.main - Initializing UI…
09:45:23.668 [DesignerExecEngine-1] INFO tags.subscriptions - Changing connected quality to ‘Good’
09:45:23.673 [DesignerExecEngine-2] WARN tags.subscriptions - Tag subscription CRC mismatch. Expected=0, received=2727171596. Will resubscribe.

Let me know for further information.

Thank you.

Dears,
I also noticed the issue occurs by swapping from the parent project to a child project (or between children projects). The strange behaviour does not occur by swapping from a child to the parent project.

Thank you.

Dears,
in the build b2019030902 the swap issue is still present.
Any news?

It looks like you’re seeing several contexts simultaneously (Vision/Alarm Pipeline), but without additional info there’s no way for us to diagnose or help you with your issue. What OS are you using? Does your project have Alarm Pipelines in place? Is this an upgrade of an existing project or is this a project built only in 8.0?

You mentioned that the issue occurs while swapping from a parent to a child. Are you swapping to a child project for which the project being swapped from is the parent of the project you are swapping to? Or are you just swapping to a project which is a child from a project which is a parent?

Thank you for your reply.
I answer to your questions:

What OS are you using?
The designer is running on a Win10 OS (Ignition on a Windows Server 2016 virtual server).
Does your project have Alarm Pipelines in place?
No, there are not Alarm Pipelines in place.
Is this an upgrade of an existing project or is this a project built only in 8.0?
It is a project built only in 8.0.

I put in place one parent project and two children projects: if I swap from one of the children to its parent there are not the strange behavior, instead the issue occurs from the parent to one of its children.
I hope top be clear enough.

Thanks again.
Andrea

I’ve opened an internal ticket to see about making the project swapping a less jarring experience.