[BUG-13424] Igniton 8 Edge Gateway- Java startup errors, Windows 7 PC

Downloaded Ignition 8.0 Edge gateway (.zip from IA site, all fresh installs of Java and Ignition) on Windows 7 machine with Java version 1.8.0_201-b09. When attempting to run installer, I get a Java error in the wrapper logs “Unable to execute Java command. Access is denied (0x5)”. All Java settings allow for browser access and other security needs. I did notice there is only a .zip file available on the IA website for Edge as it appears to now be a separate installer from a standard gateway in 8.0, which is different than previous versions of Ignition. The location that the .zip file extracted to was different than previous versions as well. Is Edge 8.0 fully functional, and if so, is there a specified file path I need to extract to to run the gateway? The 8.0 Edge installer does appear to work on Mac, but not Windows so far. It appears to be a java issue in the .zip folder. Doing a full install of a standard Ignition gateway on the same machine, then copying over the jre-win files from that install to the Edge gateway’s folder allowed Edge to start without issue.

(multiple install error logs from repeated attempts to get gateway running)

Is this a 32-bit version of Windows 7?

Do you have admin privileges?

Also - make sure there’s not already an Ignition service installed. the 2nd line of your wrapper log seems to indicate there is.

64 bit. The error is from trying to use the same install file multiple times when it didn’t work the first time. Fresh install of java and ignition, and yes to admin.

I should have read more carefully. This sounds like it might be a bug, we’ll see if we can reproduce it here.

no worries, thanks for looking into it

Looks like we’re already tracking this issue… with a noted work-around from the ticket:

Work around:

  1. Navigate to the “Ignition-windows-64-8.0.0-rc1\lib\runtime” folder
  2. Right-Click on the jre-win folder and select Properties
  3. On the General tab of the Properties window, click the Advanced button in the Attributes section
  4. In the Advanced Attributes window, deselect the “Encrypt contents to secure data” and click OK
  5. Click the Apply button on the jre-win Properties window.
  6. In the Confirm Attributes Changes window, verify that the “Apply changes to this folder, subfolders and files” is selected and click OK
  7. Now verify that the jre-win folder no longer is using green font.
1 Like

That work around worked for installation. After installation, when launching the designer launcher from desktop shortcut and selecting one of my designers from the window, I cannot type in a username or password and the popup freezes on the screen and/or tries to start several times with multiple layered windows of the same popup. Have tried re-installation as well with no luck.

You should probably call into support and let them troubleshoot or make a bug ticket if they can’t figure out what’s going on.

I tried to reproduce this in a Windows 7 VM but couldn’t.

1 Like