[Bug-13647]Vision Windows Folder Disappeared


All of a sudden the “Vision Windows” folder has disappeared from the Project Browser in Ignition 8.0. I can’t access or edit the windows anymore. I’ve restarted the gateway and designer multiple times, and even restarted the Vision module itself but to no avail. Finally I upgraded to the nightly 8.0.1 build and still the Vision Windows folder is nowhere to be found. Is there any solution to get that folder back? The clients seem unaffected.


Check on the gateway in <path-to-ignition-home> /data/projects/<your-project-name>/com.inductiveautomation.vision

If there’s a folder in there with the name ‘window’ rename it to ‘windows’. No need to restart the gateway.

Hi Kathy,

Thanks for the quick reply. The folder is already called ‘windows’. I renamed it ‘window’ and then back to ‘windows’ and restarted the designer but the Vision Windows folder is still not there.

Can you copy the entirety of the designer’s output logs and paste them here? Something is probably causing the Vision module not to load properly.

1 Like

Here you go:

15:45:39.492 [Designer-Startup] INFO designer.main - Downloading... [+0]
15:45:40.893 [Designer-Startup] INFO designer.main - Cleanup... [+1401]
15:45:40.894 [Designer-Startup] INFO designer.main - Initializing UI... [+1403]
15:45:41.046 [Designer-Startup] INFO tags.manager.gwinterface - Tag poll rate changed to 250 ms
15:45:41.136 [DesignerExecEngine-1] INFO tags.subscriptions - Changing connected quality to 'Good'
15:45:44.137 [Designer-Startup] INFO designer.main - Starting module: Vision [+4646]
15:45:44.747 [Designer-Startup] ERROR Scripting.ScriptManager.USSO_Ignition - Warning: collision at system.util.shutdown
15:45:45.069 [Designer-Startup] WARN vision.ProjectTag - Error creating tag binding for client tag '[client]AccessLevel': Syntax Error on Token: 'End of Expression' (Line 0 , Char 0)
15:45:45.072 [Designer-Startup] WARN vision.ProjectTag - Error creating tag binding for client tag '[client]Desktop': Syntax Error on Token: 'End of Expression' (Line 0 , Char 0)
15:45:50.794 [Designer-Startup] ERROR designer.main - Error starting up module Vision
java.lang.NullPointerException: WindowInfo for window com.inductiveautomation.vision/windows/SOUT/SPM/MF1/Forming_Alarm_Firstout_Setup was null.
	at com.inductiveautomation.factorypmi.application.model.WindowCache.getWindowInfo(WindowCache.java:183)
	at com.inductiveautomation.factorypmi.application.model.WindowCache.getWindowThumbnail(WindowCache.java:520)
	at com.inductiveautomation.factorypmi.designer.workspace.StartupPanel$ResourceThumbnail.<init>(StartupPanel.java:315)
	at com.inductiveautomation.factorypmi.designer.workspace.StartupPanel.createResourcePanel(StartupPanel.java:176)
	at com.inductiveautomation.factorypmi.designer.workspace.StartupPanel.build(StartupPanel.java:125)
	at com.inductiveautomation.factorypmi.designer.workspace.StartupPanel.<init>(StartupPanel.java:80)
	at com.inductiveautomation.factorypmi.designer.workspace.WindowWorkspace.openWelcomeScreen(WindowWorkspace.java:473)
	at com.inductiveautomation.factorypmi.designer.model.VisionDesignerImpl.startup(VisionDesignerImpl.java:347)
	at com.inductiveautomation.ignition.designer.IgnitionDesigner$LoadedModule.startup(IgnitionDesigner.java:1828)
	at com.inductiveautomation.ignition.designer.IgnitionDesigner.startupModule(IgnitionDesigner.java:1079)
	at com.inductiveautomation.ignition.designer.IgnitionDesigner.lambda$loadProject$6(IgnitionDesigner.java:890)
	at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.accept(Unknown Source)
	at java.base/java.util.stream.ReferencePipeline$2$1.accept(Unknown Source)
	at java.base/java.util.ArrayList$ArrayListSpliterator.forEachRemaining(Unknown Source)
	at java.base/java.util.stream.AbstractPipeline.copyInto(Unknown Source)
	at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(Unknown Source)
	at java.base/java.util.stream.ForEachOps$ForEachOp.evaluateSequential(Unknown Source)
	at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(Unknown Source)
	at java.base/java.util.stream.AbstractPipeline.evaluate(Unknown Source)
	at java.base/java.util.stream.ReferencePipeline.forEach(Unknown Source)
	at com.inductiveautomation.ignition.designer.IgnitionDesigner.loadProject(IgnitionDesigner.java:889)
	at com.inductiveautomation.ignition.designer.IgnitionDesigner$StartupProjectDialogHandler.lambda$new$2(IgnitionDesigner.java:1892)
	at java.base/java.lang.Thread.run(Unknown Source)
15:45:50.916 [Designer-Startup] INFO designer.main - Starting module: Symbol Factory [+11424]
15:45:50.925 [Designer-Startup] INFO designer.main - Starting module: WebDev [+11434]
15:45:51.002 [Designer-Startup] INFO designer.main - Starting module: Alarm Notification [+11511]
15:45:51.208 [Designer-Startup] INFO designer.main - Starting module: SFC [+11717]
15:45:52.735 [Designer-Startup] INFO designer.main - Starting module: OPC-UA [+13244]
15:45:52.735 [Designer-Startup] INFO designer.main - Starting module: Enterprise Administration [+13244]
15:45:52.755 [Designer-Startup] INFO designer.main - Starting module: SQL Bridge [+13264]
15:45:53.128 [Designer-Startup] INFO designer.main - Starting module: DNP3 Driver [+13637]
15:45:53.129 [Designer-Startup] INFO designer.main - Starting module: OpcCom [+13638]
15:45:53.130 [Designer-Startup] INFO designer.main - Starting module: Perspective [+13639]
15:45:55.757 [Designer-Startup] INFO Perspective.Designer - Starting up Perspective module.  Mode: Trial
15:45:56.513 [Designer-Startup] INFO Perspective.ViewWorkspace - Initializing JxBrowser Context with disk cache.
03:45:56 SEVERE: [0422/154556.710:ERROR:gpu_process_host.cc(1316)] Bad parenting request from gpu process.
03:45:56 SEVERE: [0422/154556.718:ERROR:gpu_process_transport_factory.cc(1018)] Lost UI shared context.
15:45:57.054 [Designer-Startup] INFO Perspective.SessionProps - Session props debug url: https://chrome-devtools-frontend.appspot.com/serve_file/@e8e14b69c41a5a461c15fa5d1065ec28c49890ac/inspector.html?ws=localhost:9222/devtools/page/1882CA896CE4F409E65B83D61535EC07
15:45:57.311 [Designer-Startup] INFO designer.main - Starting module: Reporting [+17820]
15:45:57.341 [Designer-Startup] INFO reporting.Designer - Starting up Reporting Module. Mode: Trial
15:45:58.423 [Designer-Startup] INFO designer.main - Starting module: Web Browser [+18932]
15:45:58.575 [Designer-Startup] INFO designer.main - Initializing Scripting... [+19084]
15:45:59.025 [Designer-Startup] INFO designer.main - Initializing UI... [+19534]

Can you navigate to <install directory>/data/projects/com.inductiveautomation.vision/windows/SOUT/SPM/MF1/Forming_Alarm_Firstout_Setup and take a screenshot of the files present there? If there’s a single data.bin file, does it have any content? Or if there’s a window.bin, is it similarly empty?

If you have a backup, or just want to get going again, you can try deleting the entire Forming_Alarm_Firstout_Setup directory, or just the window.bin/data.bin file(s) and then re-launching the designer.

Here’s a screenshot of the files in that folder:

I deleted the “data.bin” file and restarted the designer but the Vision Windows folder was still not there and the console showed the same error. I deleted the entire Forming_Alarm_Firstout_Setup folder and the Vision module seems to work now. Thank you and Kathy for the help.

Okay, this looks like another occurrence of an issue we’re tracking but haven’t managed to really reliably replicate yet - basically, the designer thinks that resource turned into a folder at some point, so it saved it without any data, which then causes problems on the next window load.

Whether or not that happens, we should probably avoid it breaking the entire Vision module - I’ll open a ticket for that as well. Thanks for reporting this!


As a followup we just had this happen here where I work. Had a project opened but had not made any changes, opened up a different project, declined to save on exit and when the new project opened the Vision windows disappeared entirely. My co-worker tried to load his designer and couldn’t see the vision windows either at this point. Will try the above fix.

This issue was fixed in the 8.0.2 nightly build that was uploaded today (5/8).

1 Like

When will be 8.0.2 released? I also have this problem after upgrading from 7.9.x.

Hi @niyoms,

8.0.2 is scheduled to be released sometime next week.

Any chance this could affect the named queries folder? My queries are working fine but the folder which contains those queries has disappeared.

Hello everyone, I have the same problem, maybe is not for the same cause but I am in the last version of ignition 8.0.9
My issue is that the disk of the server was full and now I cant see the vision module in my project.
I have tried to do a backup and restore it in other server and it continue not working.
What was the solution of this issue?

Thank you very much