[BUG-13855] Perspective - subview hiding table rows

I’ve been using the subviews with tables on it. I noticed that under some conditions the subview hides just the rows. The header, bottom and everything else is there. I tried to change some parameters in order to find the root cause, but I’m still not sure. Here are a few hints:

  • I’m using only flex containers on the subviews; apparently it works fine in ‘row direction’ but depending on the conditions it fails on ‘column direction’
  • Changing the basis length to be longer than the view, i.e. it will shrink, made it fail in some cases, but using a basis shorter, thus making it grow, made it work fine
  • This issue doesn’t seem to happen with Firefox, just Chrome.

Here’s a screenshot of a simply reproducible case. It works on the designer but it fails on the browser.
It’s the example table with a subview calling this subview that is a flex, column oriented, with another table.The designer shows the expected behavior.


Thanks for reporting. We have an open ticket for this already. I was’t aware of the differences in behavior across browsers, so thanks for letting us know. In the meantime, as a work around, you can either set the flex direction on your subviews to row or un-virtualize the subview table. Either one should work.


1 Like