[Bug-13924]Where have my tags gone!

I upgraded from 7.9.10 to 8.0.1 last week and have been having problems with tags since.
To upgrade, I restored the 7.9.10 backup to the 8.0.1 gateway. Some tags didn’t import correctly and didn’t show in the Tag Browser, so I move them again from the old project to the new project by Tag Export/Import. This seemed to work at the time and they all appeared in the Tag Browser correctly. Then I then restarted the Gateway, and most of the tags disappeared again as shown below!

On the web pages under Status->Tags it shows the correct number of tags, but I can’t see them in the Tag Browser

Has anyone else had experience with this?
Any advice on how I can fix it?


We have seen some instances of this occurring when a folder or tag is duplicated by a differing case (e.g. Folder and folder). We are attempting to determine how this is happening, but to resolve the issue the duplicate needs to be removed. I would advise contacting support to confirm this is the cause of your issue and correctly clean up the records should there be duplicates.


Try going into the gateway web server, go to edit the real-time tag provider but just press save. This will reload the tags. I’ve found this fixes a number of tag related issues, can’t remember if it fixes this one though

Thanks for your replies. I used a combination of your suggestions. When I logged in again on the gateway web server I found there were two Tag Providers with the same name. I deleted them both to clean out the tags, then recreated the Tag Provider and imported the tags again. They have now been working for a few days, so hopefully it won’t happen again.

This issue was fixed in the 8.0.2 nightly build that was uploaded today (5/20).

Today I renamed a folder, and it didn’t really rename it, just made it look like all the tags in that folder got deleted. Refreshing the tag browser didnt fix it. I tried to delete the folder and got a ‘Bad_NotFound’ error.

Going to the gateway and resaving the real time tag provider did refresh the tags though, and the tags in the folder re-appeared.
I’m on version 8.0.2 (b2019060511) , so not sure if the tag browser issues are totally resolved?

That’s a bug that is resolved in 8.0.3.

1 Like

Today I renamed a folder and all the tags in the folder disappeared. I am using 8.0.4

Edit: Resaving the real time tag provider solved this issue, as mentioned above by mcarritt1