[Bug-14078] Not Allowed Cursor on Disabled Buttons

Somewhere between the updates from 8.0.0 to 8.0.3 the cursor CSS property seems to have stopped working for me. I’m trying to use the ‘not-allowed’ property when a button is disabled and the light theme didn’t appear to have that in the primary button style so I added it there with no luck, tried switching back to dark theme which had it originally with no luck and also trying setting the cursor type in the styles in Designer to not-allowed which did not work.

I’m using an 8.0.3 build (though not the absolute newest) and I’m able to set the cursor to use “not-allowed”.

My steps:

  1. Create a New Style.
  2. Add an Element State modifier of hover.
  3. Set Misc > Cursor to “not-allowed”.
  4. Place a Button in a View.
  5. Set Button.props.styles.classes to the name of my Style.

If you followed the same steps (or similar and still couldn’t get it to work), please let me know and I’ll try again to replicate the behavior you’re encountering.

I followed your steps and it worked however everytime I hover over a button and it’s enabled the ‘not-allowed’ cursor is up. When I do the same steps except for on an element state of disabled it does not seem to work like it used to. The cursor used to change to the not allowed only over the button when it was disabled.

I’m also not using the latest of 8.0.3 I’m on the first release of it from a couple weeks ago.

Ah, yes, in that state it doesn’t appear to be working. This is likely a result of a recent change which modified the structure of several components. I’ll open a ticket.