[bug-14202]Template UDT Custom Property Drop Target not working properly in Ignition 8

I have several vision templates that use a UDT custom property with drop target checked off. In ignition 7.9, when I drag a udt instance onto the canvas, the templates listed in the drop down are only the ones that have that particular data type as a custom property, as it should be. After importing these templates into ignition 8, when I drag an instance onto the canvas, I get all the templates listed in the drop down instead of just the ones that have the applicable data type as a drop target. Is this a bug in ignition 8. I have tried on 8.0.1 and on the latest 8.0.2 download.

This is a known bug; thanks for the report!

Is this bug still present? I am still seeing this behavior in 8.0.3

I’m still seeing this bug as well in the 8.0.4-b20190826 nightly build.

Yes, we haven’t yet fixed it. It’s on our list, but hasn’t yet come to the top of the priority order. We’ll update this thread once a fix is completed.

1 Like

Fixed for 8.0.16.

1 Like