[bug-14225]Gateway name pop-up when installing v7.9.11

When installing v7.9.11 I am prompted with the window below to enter a Gateway name to use on restore. What causes this prompt to be displayed and is there a way to supress the prompt, or possibly pass in a parameter for the Gateway name non-interactively?

Also, is the Gateway name the name of a supplied GWBK file such as the Gateway name would be MyTest if the GWBK provided was “MyTest.gwbk”? Or would it be the Value to use for the “System Name” in “Gateway Settings”?

The latter - this will override the gateway name that’s already in the config.idb in the gateway backup you’re restoring, and force it to initialize with a new name. That’s useful if you have a “core” .gwbk that you’re restoring to many sites, that might be storing history immediately.

You can bypass most of the checks with the -y flag, but it looks like (double checking the internal logic) there is a bug here, that we still prompt for a new gateway name even if you’ve passed that argument. I’ll file a ticket to fix that.

Agree that -y should bypass it. Perhaps we can add another command line argument to be able to explicitly specify an alternative name?

1 Like

This issue was fixed in the 8.0.3 nightly build that was uploaded on 7/11.