[Bug-14441]: Alarm emails were sent error with SMTP profile

As Title, we are not allowed to send email with user name and password, so I just leave it blank.

Similar links

The username and password are those of the account for the SMTP Server account. Without a username and password for the SMTP account, the server will not allow access because you have not authenticated with the service.

For clarity:
If I were to use Google’s GMail as my SMTP server, I would need a GMail account, in addition to my Ignition account. This screen is requesting the credentials for the GMail account. Without the GMail account’s username and password, Google will not allow me to use them as an SMTP server.

alot of companies dont require username and password to send emails. gmail would require it.

I would try and set this up directly on the email notification profile as opposed to using the smtp profile setup on the gateway. I seem to have run into a bug where the smtp profile wouldnt work but setting this up directly on the email notification profile worked fine.

It works as charm after I don’t use SMTP Profile, thank you bro! @diat150 .
By the way, @cmallonee this is a bug please follow it and report to your developers soon.

Hi @diat150 and @weixionglichina -

I suspect that you have a non-empty password set in the SMTP profile. If you were to go to your SMTP profile, check the box to change the password, and leave it blank, then save, then use the SMTP profile instead of the direct email notification profile, does it work as expected?

This issue was fixed in the 8.0.4 nightly build that was uploaded today (7/29).

I have come across a similar issue where the SMTP server requires only a username and a blank password. I configured the an SMTP profile with the appropriate settings and I can send emails using the test function. However, when the SMTP profile is linked to a Email Notification Profile and then subsequently called by an alarm pipeline I get the following error in the gateway event log.

I originally discovered this issue in v8.0.2 and upgrade to 8.0.4 after seeing the posts on this thread.
I still have the same issue in v8.0.4.

It seems as though the Email Notification Profile does not like having a blank password field even though the SMTP profile works with a blank password .

Nathan,

I realize this is late, but perhaps it can help you or someone else.
I ran into this same issue, and found that when trying to send via an SMTP server with a username and no password, I had to:

  • Configure the SMTP server with the hostname, but no username
  • Put the username in the From Address of the notification block.

This allowed me to send via the alarm notification pipeline.
Read more here:

AIO,

I resolved this issue as I found that i was able to utilise the SMTP server with blank username and password fields in the SMTP Profile configuration. The IT team that provided me information on the SMTP server at the time did not understand how it worked and provided me with incorrect information.

Thanks for the useful info though, I am sure it will come in handy in the future.

1 Like