[Bug-14458] Changes saved if clicking cancel on 'Edit Group Tag'

I’m on the 8.0.2 Release. It appears that if I make a change(such as changing the name) and hit cancel instead of OK or Apply, the changes are still saved to the transaction. I’m guessing this isn’t intentional behavior?

Some further testing today shows that if it is a memory tag, the issue doesn’t occur, but it does if I am editing a tag that was created by dragging from the OPC browser.

I tried to replicate this behavior today but I’ve been unable to. Based on the information you’ve provided, we’ll need a better explanation of the steps you went through to encounter the described behavior. Also, your two posts describe different interactions, which is leading to some confusion here.

Could you please provide a step-by-step walkthrough?

Here are the steps I followed, without encountering the issue for a Tag Group:

  1. In the Tag Group Editor Dialog, double-click a Tag Group
  2. Modify the name to something new.
  3. Press Tab to remove focus from the input.
  4. Click Cancel.

End result: on re-opening the Tag Group Editor, my tag Group has the same name it had before I attempted to modify anything.

Modifying a Tag which belongs to a Tag Group:

  1. Right-click a Tag to open the Tag Editor.
  2. Modify the name to be something new.
  3. Press tab to remove focus from the input.
  4. Press Cancel.

End Result: a Message Dialog appears to inform me that my changes will not be saved. On Clicking Yes, the Message Dialog and the tag Editor are closed, and my Tag has its original name. If I elect to click “No”, then the Tag Editor remains open with any changes I’ve made, although those changes are still not applied to the tag I have been editing.


I made a quick video since I figured it was easier to follow than my rough instructions. I never got a Message dialog to confirm changes, but as you will see it still updates my name after I close the window.

Yes the video is much more clear because you hadn’t previously mentioned Transaction Groups in any capacity. I’ll resume my investigation and update this thread when I have something more.

I’ve opened an internal ticket to track the issue after replicating the undesirable behavior.