[BUG-14463]Alarm Pipeline drawing freeze Designer


I have currently restored a 7.9.10 gateway backup to a 8.0.3 gateway.
The nightly build is from 1 week ago, I cant find the exact build as it stands “Dev Version” on the status page.
The previous alarm-pipelines from the 7.910 gateway backup are working.

But when im trying to make a new alarm pipeline, and draw from the Start block to Notification block, the whole designer freezes.

I have tried on a different gateway where there is no restored backup applied, and its working fine. On both Designer (computers)

I have tried on a different computer, on the restored gateway, the designer doesnt freeze, but doesnt allow me to draw either.

Is there something I have overlooked?

Ok I just tested another thing.

On the gateway that didnt have the 7.9.10 version installed before:
I restored the backup project from the gateway that “failed” the pipelines, and I can draw and make new pipelines on this gateway.

So it seems that something is bugging when you restore a project to the same server that version 7.9.10 was installed on. Im gonna try more later today.

This appears to be something that was broken recently with the nightly builds. It probably worked on your other gateway if it was an earlier 8.0.3 build, but on the most current build it looks like connections between alarm pipeline blocks is not working at all. I’ve written up an internal ticket for this and it will likely get fixed soon.

1 Like

Hi, I just downgraded it to the version that had the pipelines working, and its working now on both gateways.

Seems like youre right, something has broken it in the last few nightly’s.

This issue was fixed in the 8.0.3 nightly build that was uploaded today (7/18).