[BUG-14688] series.visible property on XY Chart having no effect

I have various bar-type XY Charts on my project (currently running 8.0.3 RC2) and previously, before updating to this version, I would use the series.visible property to show/hide series dynamically. For some reason, however, the series.visible property no longer has any effect at all anymore. It causes the chart to flicker when changing it in the designer but the series stays visible.

Well that’s sad. Obviously this is a regression as a result of upgrading the lib to resolve the memory leaks. We will look into this. Thanks for reporting.

I think the problem persists in version 8.0.6.
I try to put a very simple expresion to bind the visible Mete-property ({view.params.Visible}=1) and it seems to work well in the designer, but in the app you never see the component.

Do you know if it will be fixed in the next upgrades?


I was wondering if there was an update on this as well. I did get it to mostly work by binding to the “defaultState - visible” property of the series however when you turn on bullets on the line they show up even though the series itself isn’t visible. We are in 8.0.6 as well.

Any updates on this? Running into the same issue in our project

1 Like

This has been fixed as part of 8.0.10

This is still an issue in 8.1.3

I’m not able to reproduce locally on 8.1.3. Are you using the XY Chart and enabling/disabling the series.visible property?

Yup I have 3 series and none of them disappear from the chart with any of their respective visible props. If I enable the legend, and deselect it there it works but I was hoping to use a script elsewhere. I can see my script working in the designer.
Stack or unstacked same thing. The lightest green is “Shift 1”

I think the issue still exist in 8.1.6 on XY chart. I add a label on the view with the XYChart.props.series[0].visible property. If I hide the serie by clicking on the legend option, the serie is hided on the graph but the visible property is still set to true. I try the set the visible property with a toggle button but the property is not set to false, always set to true.
Could we hope a fix?

Still an issue in 8.1.10.
Has this been fixed in later versions ?

There still seems to be some funny business going on with the series visibility property. When adding a series, 1 first instance is invisible even though the visibility property is True. Toggling it (True->False->True) makes it visible. Adding a 2nd series will also make it visible. This is version 8.1.16