[bug-14981]Intermittent tag quality overlay

Hi all,

I have a popup window that makes extensive use of indirect tag binding. I pass the tag path to a UDT tag to the window when I open it, and it pulls dozens of tag elements and tag properties to build the screen. When I open the popup on a client, there are a handful of objects on the screen that intermittently give me bad tag quality overlays (the “not found” overlay). It’s always the same handful of objects, all of the others work consistently. I can click a button to open the popup, and it will open with everything working perfectly, then I can close the popup, click the same button to open the same popup, and one or two of those objects will have a problem. The objects actually still work - e.g., I have a numeric entry field, and I can enter a number and it will update the PLC tag. But still, the bad tag overlay. If I disconnect the PLC and let the bad tag overlays appear on everything, once I re-connect the PLC, everything begins functioning correctly.

How might I start troubleshooting this?
I get nothing logged in the client console.
If I assign a tag path in Designer, the display works perfectly.
All the tags in the UDT are reading OK in the tag browser.
I am logged into the client with a user account that has all roles.

You may not be getting the throughput from the PLC you think. Look in the gateway at your driver diagnostics.

Update: I seem to have fixed it, but would be interested in learning why the issue occurred so I can be aware of it in future…

The popup window has custom properties called “PVMin” and “PVMax”. These are bound to elements within the UDT. I then scale graphics and enforce entry limits on numeric entry fields by binding to these custom properties. I changed the affected objects to use use indirect tag binding (binding to the UDT elements themselves) instead of property binding (binding to the custom properties that were bound to the UDT elements), the problem seems to go away.

So, if I had to guess, I’d say that the custom property binding was sometimes “incomplete” when the other objects on the screen tried to use them for binding themselves. Does this sound plausible?

Looking at the driver connection details for this PLC, the load factor on all my scan classes is below 10% with or without this popup open - I don’t think that’s causing the issue

I’ve run into this same issue and the same solution. If component properties within a template are bound to tags via indirect binding, they work as expected. If, instead, internal template properties are bound to those same tags via indirect tag binding and then component properties are bound to the internal template properties, we get somewhat random quality overlay issues. Seems like a bug.

I guess so. Worth raising a bug report with IA perhaps?

I face this issue also check OPC connection and tag quality both all good but still overlay problem

I’ve noticed that the bad quality overlay on the component goes away when the tag it indirectly depends on changes value. I haven’t taken time to test the theory, but this leads me to believe the issue may be that an initial component binding evaluation with bad quality is not getting re-evaluated when the quality of the custom property it is bound to changes. Then it is re-evaluated when the value of that custom property changes which clears the quality overlay (assuming underlying quality is now good).

Was a bug report ever filed? We’re on 7.9.10 and seeing a similar issue with random quality overlay issues when using component properties bound to internal template properties. I checked changelogs for 7.9.11 and 7.9.12 and see nothing about improvements for indirect tags.

Our defect analysis team actually recently got to what we’re pretty sure is the root cause of this. We’re looking into what can be done to fix it - no timeline on a fix yet, but we’ll post back to this thread.


We’ve just merged a fix for this that will be in for 7.9.13.

1 Like

I also have this same problem, though tag quality is 192, it still shows tag overlay.
I know this button will work. If I click on this, particular button, it will start the motor. So it is communicating from client to server to PLC…
Any suggestions would appreciate…

I am using 7.9.12.


Thanks @awalker! Does this mean this fix is in an 8.0.x version too?

The issue discussed here relates to component properties bound to template internal properties. It looks like you may have a different issue as your example doesn’t show a template. You’ve selected the Packer Blower group in the tree. Check all the components and bindings under that as well and you’ll likely find the issue. Or try right-clicking on the component and choosing Diagnostics
and look for anything listed that is not green.

Hi @witman,

We were never able to reproduce the same issue in 8.0+.

Is this something that you were seeing in 7.9 or 8?

Thanks @awalker, we;ve only seen this in 7.9. We’ve moved one Vision installation to 8.0.4 and haven’t noticed the issue, but it’s a simpler project where we hadn’t seen it in 7.9 either. The more complex projects that regularly exhibit this issue are still on 7.9, though it looks like the bug fixes on 8.0.6 may resolve enough of the issues we saw on this first one to try migrating the bigger projects to 8.0. Whether with 7.9.13 or 8.0, having this bug fixed is great!

1 Like

That’s great to hear! Yes, if you come across any other issues please let us know!

1 Like

Thanks Witman. I did that diagnostics and everything is Good. but the group control buttons still shows tag overlay. Any idea what could be the problem?

Hard to say. Is this behaviour consistent, or intermittent? If it’s consistent, I’d expect a binding/tag/underlying data issue. If it’s intermittent, it may be a bug.

You could make a copy of the PackerBlower group (to leave your original intact) and–assuming the copy shows the same issue–remove/replace one binding at time till you find the one that clears the overlay when it is removed. Then dig into/post the details of that binding and what’s behind it.

It is intermittent and some time, if I change back from another tab, this will be back to normal and again it goes back to this tag overlay . It is not with all buttons, and not only the control group buttons.
It was even showing for a pipe segment too.
I never had any issues on 7.5. The project was (originally it was built on 7.2 ) imported to 7.9. Would that be causing these issue?