[bug-15415]How to go about finding the tag populating gateway logs with error

I looked at my logs today and found it filled with several pages with the same error on an expression tag. How do I go about figuring out which tag this is?

Weird that the logger is null too… Does the magnifying glass on the right have more info?

Log Properties
tag-provider default

Well… at least you know what tag provider to start looking in :laughing: :sob:

Is this 7.9 or 8.0?

If you click the logger name, is there any logger name before the null?

v7.9
The only other thing I see is it shows Expressions.null if I hover over the null

EDIT
It started just after midnight today, and stopped at 6:18am

If it’s not still happening it’s too late to find out what tag it was.

I guess I will just keep tabs on the logs and see if it starts again, then try to pinpoint it before it stops.

If it happens again, go to the logging area in the gateway and search for “Tags”. Turn the base logger to DEBUG level. This will turn all Tags.* loggers on and may be pretty spammy, but hopefully you’ll see something about an error executing this expression tag.

1 Like

Pretty sure it’s one of the get*(<date>) functions; I see the bug.

1 Like

Well, it won’t help much with where it’s coming from or why it stopped happening at 6:18…but the bug with the logger name being null will be fixed in 7.9.13 :slight_smile:

3 Likes

Found it, it was a leased tag which is why it was in the logs only at certain times. I wrote a query tag that didn’t take into account the situation where no rows were returned, and it was in another expression tag which gave the error. Thanks for the bug fix

3 Likes

This does not appear to be fixed in 7.9.13. Did the fix get implemented?

It did. To clarify, you’re still seeing the issue with a logger named null? Is there any other attached information? Same error message being logged?

This is what I have in my logs. I updated from 7.9.12 to 7.9.13 to attempt to get more information, but there was no change.