[Bug-15769]: map .props.layers.vector.polylines.stroke.enable binding doesn't work

Hi
I try to show and hide some polyline base on user current zoom level. I bind zoom level to “map.props.layers.vector.polylines.stroke.enable” property of map component but changing value from true to false doesn’t work at all at run-time.
If I set to false and save view and open browser the poly line hide but make it dynamic doesn’t work.

The current zoom level doesn’t appear to be a property on the map component. Were you binding to the init zoom level? That property doesn’t change when zooming around on the map.

Hi
I create zoom custom property on map. and use onZoom event script.
Any way if I use kind of dynamic binding on map.props.layers.vector.polylines.stroke.enable property it doesn’t work on run time.
It only work for initial state.
You can test it simply by binding it to button in view to trigger true and false and see nothing happen even I see the property is change from true to false correctly.

I see it now, I’ll get an internal ticket written up for this. I also noticed this also affects the opacity property which I had tried to set to 0 to get the same effect.

Yes exactly I set opacity to 0.0001 to work.

Hi sorry for commenting on an old thread, but I’m having the same problem.

I can set a polyline.stroke.enabled from True to False and the line disappears.
False to True does not work. Was this bug fixed?

This bug has not been worked on no. I am seeing the same thing you are now though where it will disappear but not reappear when enabled. It’s likely just a consequence of other changes that occurred within the past 8 months. I’ll make a note of this new change in our internal ticket.

1 Like