[Bug-16253] JVM crash after upgrading to 8.0.10 on linux

I just tried to upgrade my production system on a linux server under Hyper-V to 8.10. The upgrade failed with the following error:

 Error running /usr/local/bin/ignition/lib/runtime/jre-nix/bin/java -classpath
"lib/core/common/*" com.inductiveautomation.ignition.common.upgrader.Upgrader
"/usr/local/bin/ignition" "/var/lib/ignition/data" "/var/log/ignition"
file=ignition.conf: Aborted
Press [Enter] to continue:

Setup has finished installing Ignition on your computer.

Start Ignition now [Y/n]: Y

Error: There has been an error.
Error running su root -c '"/usr/local/bin/ignition/ignition.sh" start': child
process exited abnormally
Press [Enter] to continue:

Trying to manually start Ignition also does not work:

# A fatal error has been detected by the Java Runtime Environment:
#  SIGILL (0x4) at pc=0x00007f66379137f2, pid=1891, tid=1892
# JRE version:  (11.0.6+10) (build )
# Java VM: OpenJDK 64-Bit Server VM (11.0.6+10-LTS, mixed mode, tiered, compressed oops, g1 gc, linux-amd64)
# Problematic frame:
# v  ~StubRoutines::call_stub

Upgrading on a similar test system worked without problems.

Any ideas what could be the problem?

Is there a crash dump file generated anywhere?

Yes, but it is not really helpfull:
hs_err_pid1891.log (41.9 KB)

Maybe not, but we need something to submit to Azul.

Replacing the jre-nix/lib folder with downloaded files from azul community 11.0.5 lets the gateway start again.
Everything seems to run normally.
Can you say which Ignition version had the upgrade to 11.0.6? The only difference to my test system is the previous Ignition version. 8.0.6 on production system, 8.0.9 on test system.

It was upgraded to 11.0.6 in Ignition 8.0.10.

Ok, thank you.
I will open a support ticket for this problem.

Ok that’s fine. I pointed another engineer to this thread and he’s opened the ticket with Azul using the crash dump. Hopefully this is resolved quickly.