[Bug-16797] Ignition Gateway Start on Linux on boot

We are running Ignition 7.9.10 as an OPC server on a Linux headless host (Ubuntu). We have another Ignition instance that is running our project/tag configurations which connects to the OPC server. We have lost power to the host a few times and it seemed Ignition failed to start back up cleanly. I needed to Putty on and start the Ignition gateway. Do we need to configure Linux to startup Ignition Gateway on boot up or is this already handled during the initial install? If so I assume I need to give the start script root creds and run the following script (“sudo some directory ./ignition.sh start”)

You should be able to run ./ignition.sh install to install it as a service.

Thanks Kevin. Is there a way I can check first that it is running as a service? I’ll probably try a clean restart today of the host to see if it starts up.

This depends on your version of Ubuntu, but for most recent versions, you can use the systemctl command (as root).

These are pretty simple commands:
systemctl status ignition – Check the status
systemctl start ignition – Start it now
systemctl stop ignition – Stop it now
systemctl enable ignition – Autostart on boot
systemctl disable ignition – Remove the autostart symlinks

Older versions of Ubuntu generally use init scripts.

1 Like


Can you confirm, how can I do same with RHEL version 8.
Am not able to use above commands in RHEL v8., getting error " Unit not found".
But service is running.

OS version RHEL 8
Ignition Gateway version 8.0.14

Can you show the contents of the ignition.service file (usually in /etc/systemd/system or /lib/systemd/system)?

Unit is a part of that file, so systemd not finding it sounds like your service file is corrupt in some way.

Perhaps reinstalling works too?

Below are the content from service file,


ExecStart=/usr/local/bin/ignition/ignition.sh start sysd
ExecStop=/usr/local/bin/ignition/ignition.sh stop sysd


In current versions of Ignition, I believe the unit file has been renamed to “Ignition Gateway.service” or something like that. I’m still using “ignition.service” for my custom Zip installs. Unit files really should not have a space, and I don’t know of any with uppercase letters…

1 Like

So now you need to systemctl start "Ignition Gateway" ? That’s annoying.

Thanks for the correction in any case. I didn’t have a recent systemd with Ignition install handy. Most of our test projects run in a docker (which uses Alpine and thus openRC).

Hmm, I agree that the unit being renamed is probably wrong. I’ll see if that was intentional or not.

1 Like