[Bug-2259] Unable to install new rev on Mac, malicious software

I am aware you can right click and choose Open, but it is not working.

I downloaded ignition-8.1.17-macOs-64-installer.dmg. If I try to open, I get:

If I right click, I get the option to Open, but when I press Open nothing happens:

If I right click again, I get a new dialog for osascript. When I enter my admin credentials, nothing happens:

How do I fix this?

Hi @pdixon,

This is due to our full installer not being notarized at the moment. There is a ticket for it, but due to the limited number of installs of full gateways on mac and the presence of a workaround it hasn’t been high priority.

See our Knowledge Base Article to get up and running

Additionally: The Launchers (which are used with much greater frequency) are notarized and do not require the workaround

hope that helps.
Jonathan C

Or use zip file instead of installer

I don’t know what this means. When I download Ignition I get a dmg file. Is there some other way to download that will give me a zip?

How do I download a launcher?

Follow the link for other platforms and versions.

Just go to download page and look for macOS zip file

I am unclear on the upgrade instructions. What I see is:

  • Upgrading existing installation *
    Note: Maker Edition installations should not be updated using a ZIP installer. Instead, please use the latest graphical install wizard which now supports both installations and updates to all editions, including those originally installed using a ZIP installer.
    If you are upgrading from a preexisting installation, follow these steps:
  1. Take a Gateway backup from the running system and store in a safe location.

  2. Stop Ignition. Run:

    ignition stop

  3. Delete both the “lib” and “webserver/webapps” folders.

I assume this is under /usr/local/ignition?

  1. Unzip the new zip into the current folder and allow files to be overwritten.

I downloaded to /Users/patrick/Downloads. Can I unzip there?

  1. Set the executable permission on all .sh files in the unzipped folder: chmod +x *.sh
  2. Unzip the new runtime : tar -C lib/runtime -xf lib/runtime/jre-mac.tar.gz

Since under step 3 I already deleted the “lib” folder, where are these files?

  1. If this is a major version upgrade (8.0 to 8.1) then the data/ignition.conf file may have changed. If this is a minor version upgrade (8.0.1 to 8.0.2) then skip to step 8.
    To upgrade the ignition.conf file for a major version upgrade, run the following:

    ignition runupgrader

  2. Start Ignition. Run:

    ignition start

yes, If that is where your install is. all the path references in the readme are relative to your install location

Well if its an upgrade you should unzip it to where your existing install is.

They are in the zip, so once you unzip it into the existing install directory (I assume /usr/local/ignition based on your earlier comment) the new libs will be present

After spending some time trying the launcher (command line interface) method, ending up with permission errors on usr/local, I tried the knowledge base article using sudo (https://support.inductiveautomation.com/hc/en-us/articles/360055822731--Can-t-Open-Installer-on-macOS). That fixed it.