BUG-2421: Report Viewer Print Error since 8.1.5 Upgrade

Hello All,
This was working before the upgrade:
Clicking on the print icon in the report viewer from within Workstation
is producing this error-

However using the same process from the URL works and the report opens in another window for printing.
Default browser is Chrome
Workstation Application settings are-
Launch Mode - Windowed
Tab/Window Links - System Browser
Any suggestions?

Bug reported. We are looking into this immediately. Thanks.

Thank you.

@j.kennedy : What version were you using before the upgrade?

Several of us have tried to find the point at which this “broke”, but it is our determination that opening the report in a separate tab (opening an external tab with the report present) was never functional.
8.1.1, 8.1.2 → No action is taken when the “open in new tab” button is clicked because Workstation only allows for one tab.
8.1.3+ → External tab opens, but user encounters 401 Error.

@j.kennedy : At this point we recognize that this is not working, but we’re unable to determine how it was ever working for you. We’d appreciate some clarification on what version you were using when this worked. We’ll address this issue as a normal bug, but until we can verify it was working at some point we won’t address this as a regression.

8.1.1 was being used.
The site manager have printed from a specific report created. He had no way of knowing how to access the relevant public port to access the URL to print it any other way, unless he pdf’d the report to do so. I would have to confirm.
I came across the issue only after the updgrade when trying to print to a new printer onsite.
Hence I believed it was specific to the upgrade.

Hi j.kennedy, I have researched this issue and determined that it likely hasn’t ever worked and have verified so in every version since 8.1.

The short of it is:
There are technical/security limitations that will necessitate that we treat the prop allowOpenInTab on the ReportViewer component as false in Perspective Workstation.

The long of it is:
When a report is generated for opening in a new tab, the report is temporarily stored in a manner that is only accessible from within that session. When Perspective Workstation opens a the system’s Web Browser, that new Web Browser does not have a session, hence the 401 when the new Browser attempts to open the URL.

In researching this issue I’ve considered a number of alternatives:

  • Base64 encoding the report and trying to pipe it to the System’s browser - appears that the system’s Browser can’t handle that large of a string
  • Storing the report in a manner that doesn’t require a session - security concerns
  • Allowing opening the PDF in the main Perspective Workstation main window only - awkward as it navigates you away from the view, forcing users to use keyboard shortcuts to navigate back
  • Treating allowOpenInTab as false in Perspective Workstation, and suggesting use of allowDownload prop instead to open the PDF externally - least risk, and doesn’t affect non-workstation users

Conferring with other developers/QA we have come to the joint conclusion that the last option is best.

For now, I suggest setting allowOpenInTab to false, and allowDownload to true instead. The PDF can then be downloaded through Perspective Workstation, and then opened in the PDF viewer of choice.

I’m sorry for any inconvenience this may have caused.

I get a similar error, but mine is Error 403 Forbidden on the new window that gets opened when I click on the Open in new window button. But if I close the window and press the button again, it works/loads fine. This only happens intermittently. What’s that quote about insanity…do the same thing twice and expect different results. I’m on 8.1.4

Hi All,
I understand your efforts on this, and thank you for it. However, as I mentioned in my initial post, it all works fine using the URL, our client is happy with this, so we will continue with that until it is fixed up, which I am sure will be soon.