[Bug-2650]The "maxbounds" property of map component is missing in v8.1.4

The “maxbounds” property under the zoom section of the map component is missing in 8.1.4

1 Like

I don’t see that property in 8.0.10, I don’t see it in the 8.0.X documentation, and I don’t see it in the 8.1.X documentation. In what version do you believe this property existed?

I see it in 8.1.5 and 8.0.12.
Here is the screenshot of 8.1.5:
unknown

Even in 8.1.5 I don’t see that property by default - I had to add it myself. Plus, after adding the property I had to add each individual internal property and then convert it to an object. I’ll inform Dev to see what happened here.

1 Like

The instersting part is if I hover the mouse over I get IA tooltip so it show I didn’t create it manually.
It is my bad luck that I always have to deal with very strange bugs :stuck_out_tongue_winking_eye:

No, this is definitely an IA property, but something changed recently to cause it to no longer display by default. I can’t find anything documenting that this was intended (although I could see an argument for why it might be intended), so I’ve opened an internal ticket to fix it. When the issue goes through our bug-scrubbing process they can determine if it is a bug or intended behavior.

1 Like

Oh please make available again which is very useful.

1 Like

Does maxBounds work for you? It doesn’t snap back to the corners I specified… Is there another setting that needs to be set?

I see it before and doesn’t test it but now which I want to test it, it is gone.

Oh I see. Deep-select the Map component, go to Props → Add Property → hover over Properties → click on maxBounds. Then right-click maxBounds in the Property tree → Change to Object. You’ll then be able to add corner1 and corner2, with the lat and lng values for each corner. Part of the problem is that the property doesn’t get added as the correct type (as a value instead of an object).

The other, bigger issue is that the maxBounds property doesn’t seem to affect the map in any way.
image

1 Like

@cmallonee
Did this ever get resolved. We see this property is existing when we try to add new properties but it does not seem to work.

Not until 8.1.7 and it doesn’t seem to be in 8.1.8.

The issue has not yet been resolved as of 8.1.8 development. I would not expect it to be part of the 8.1.8 final release.