[BUG-446] 8.0.16 - Dataset is automatically converted to an array when binding


After upgrading to 8.0.16, I am getting an error because a dataset property binding is now being converted to an array.

I solved my problem, but I don’t think it should be happening

	query = """
			SELECT C.competencia, AVG(RA.nota) AS media
			FROM resultadoAvaliacao RA
			INNER JOIN competencia C ON C.idCompetencia = RA.idCompetencia
			INNER JOIN avaliador AR ON AR.idAvaliador = RA.idAvaliador
			INNER JOIN avaliacao AO ON AO.idAvaliacao = AR.idAvaliacao
			WHERE AO.idAvaliacao = ?
			GROUP BY RA.idCompetencia
			ORDER BY C.competencia
	return system.db.runPrepQuery(query, [value])


Are you using a nightly build or the stable release? We encountered this in early nightly builds of 8.0.16 but we worked to fix it before stable release.

I am using a stable version. I downloaded it on 08/27/2020 at 15:22. Linux x64 installer

Actually just created a support ticket for this same thing

I am passing my dataset in a dictionary to a viewParams for an accordian.

I’m in 8.0.15 Stable