[BUG-5845]Reports and URL based dynamic images - unable to use HTTPS URLs?

I’m trying to follow almost exactly the dynamic image example from the docs. I am failing to get it to work. Nothing ever shows up in the preview.

My parameters:

My image properties:

The gateway is running in a cloud architecture w/ restricted networking, so firewalling could feasibly have been an issue. I convinced myself that wasn’t it by logging into the shell account of the user that runs the gateway and did a wget of the same URL from the command line. That worked fine.

What else could I be doing wrong?

(Ignition 8.1.3)

EDIT: I finally got it working by trying a URL with basic HTTP (not HTTPS). Is the reporting engine unable to support HTTPS image fetches? The certificates on the server I was fetching from are chained from a well-known CA, so that shouldn’t be an issue.

Alright … Here’s a list of lessons about using dynamic images from the Image Manager in reports that I’ve learned by trial-and-error in the past day:

  1. As of Ignition 8.1.3, you cannot use HTTPS URLs to fetch images for reports.
  2. You cannot reference images in the Image Manager simply with a key of /system/images/blah.jpg
  3. You cannot reference images in the Image Manager using https://localhost:8043/system/images/blah.jpg (see item 1 above)
  4. You cannot reference images in the Image Manager using http://localhost:8088/system/images/blah.jpg if you have “Force Secure Redirect” enabled in the Gateway Web Server settings
  5. The Designer cannot preview images in reports that reference http://localhost:8088/... since the preview tries to do the fetch from the Designer computer, which doesn’t have a web server running on it (normally).

If you disable “Force Secure Redirect” and use a URL like http://localhost:8088/system/images/blah.jpg and run the report on the gateway, you can dynamically fetch an image from the Image Manager into a report.

Some of my difficulty was because our gateway is running inside a fire-walled private network, and my designer session is outside that network.

Is there a better way to do this? In particular I would like to keep “Force Secure Redirect” enabled.

Any idea how to resolve this issue . I am also facing the same issue with the images not able to render in the reports with secured links.


Oof. There’s just a straight up bug in the reporting library that HTTPS urls will never even be attempted. I’ll file a ticket (and @justin.brzozoski, sorry we/I never saw your original post :grimacing:)

As a sort of workaround as of 8.1.16 you can use binary data in a report parameter, so you could fetch your images separately and pass them into the report. Far from ideal, but would make this easier I think.


Actually, nevermind, it looks like this was fixed in 8.1.10:

Thank you. I am on older version. For now I have mapped the physical path which has worked.

Doesn’t seem like it was fixed. I was able to display images on the Perspective image component via web dev script, but when I used it on the image component on the report, it did not show anything.

You should contact support and explain what you’re seeing in more detail.