[BUG] 8.1.0rc3 Nested UDTs not showing any tags


Tank 1/2 UDT instances below contain nested UDT instances (drain valve, etc.) however when I try to look at the tags within these nested udts, it’s empty… I tried to expand all of the UDT instances in Tank 1 and left Tank 2. If I expanded Tank 2’s UDTs the same thing would happen as in Tank 1.
I’ve tried restarting the tag provider, OPC-UA, and gateway with no change :thinking:

I can read the tags from a component binding, I just can’t see them in the tag browser

This one’s kind of stalled my development…


This issue was found after the RC3 release, and has been fixed for 8.1.0 final.

For now, overriding any property of a tag in the nested instance should get all the tags in the instance to show up in the browser. Once saved, you should be able to remove that override and still see the nested instance tags as well.

1 Like

This work around sort of works, but not consistently. Many of my nested UDT instances still don’t have any tags shown even after property overriding tags within the nested udts. I tried in the udt definition level as well as at the instance level. Hopefully the final release is still on track for the 2nd! :slight_smile: