[Bug?] 8.1.14 Not respecting Client Background Color in Designer

On previous versions of Ignition, the background color when editing a Vision window reflected the Client Background Color property within Project Properties > Client > User Interface. It doesn’t seem like that’s the case anymore.



Is there any way to change this? Sucks not having any contrast between the window you’re working on and the background.

Looks like this was working on 8.1.7, but stopped working on 8.1.9+. Looking at the release notes, there were a lot of updates included in 8.1.9 relating to Visualization - Swing including an update to the Look-And-Feel :frowning:

That’s not what my window vs background looks like… I bet we’re holding on to something in the window from the upgrade. If you make a brand new window, it still looks like that?
This is mine, for comparison:

During the change to the LaF, a decision was made to standardize the ‘empty workspace background color’ and not use the Vision related BG color, though I could see how that’s not ideal.

Hey Paul,

that’s what my default looks like as well

I was referring to the ‘empty workspace background color’

we have over 1000 windows using the color of the window background in the original image (218, 218, 218), which is far too similar to the ‘empty workspace background color’ (216,216,216).

I’m assuming that there’s no way to change it without you guys adding an option in?

It doesn’t look like it, no. I looked around to see if there might be a way to hack it in and didn’t have any ready success.

1 Like

Well that’s a bummer! D:

I know you guys made this change on purpose, but could this still be considered a regression?

I don’t know what all goes into supporting this in your LaF, but I imagine this affects anyone who uses a similar window color to the new default ‘empty workspace background color’

1 Like

I don’t quite want to say no… but I also don’t want to say yes, either. I’ll check in and see if there’s anything we can do.

1 Like

Awesome! Thank you for your help. :smiley: