[BUG] 8.1.4-rc1 Designer crashes multiple times a day

I have a support case for this already, but thought I’d see if anyone else has noticed this issue?

Since upgrading from 8.1.3 to 8.1.4-rc1 (b2021031812), I’ve been noticing that my Designer is crashing periodically, maybe 2-6 times a day when working on Perspective Views.

It seems to unfold like this:

  • I’m creating / modifying Views for hours, switching applications every so often (e.g. to notepad++ / file explorer etc.)
  • Then go to open a new View or even just work on existing open View after switching applications back to Designer and the View just shows a blank light-grey page (same as when you first open a View prior to the “loading…” text showing up). The View never loads. I try to open another View and it doesn’t change page. I can still click on things in the project browser and tag browser, but aside from selecting the item, I can’t do much else. Finally an error pops up. Either this one
    image
    more commonly this one:
Message:
(the message area was blank)

Details:
TimeoutException

Ignition v8.1.4-rc1 (b2021031812)
Java: Azul Systems, Inc. 11.0.9

or this one:

IllegalStateException: Failed to receive the response.
caused by IllegalStateException: The connection has been closed.

Ignition v8.1.4-rc1 (b2021031812)
Java: Azul Systems, Inc. 11.0.9

Saving doesn’t work either to save changes to unsaved Views. The only thing I can really do is File → Open, and re-open the project without saving changes. This appears to work most of the time.

Screen capture of the issue:

1 Like

I see this issue a lot. mostly wih TimeoutException and that is why I save every 5 sec. :sweat_smile:
I’ve seen these issue even in older version, but somehow it getting worse in v8.1.4rc1.

Yeah, I definitely haven’t seen it this bad as in 8.1.4-rc1… it was happening to me on the hour the other day. I can’t wait for the day that Perspective has the performance and stability of Vision. I was the one in the office always trying to get Ignition into projects, but at the moment I’ve been staying quiet as these performance issues are just killing me :frowning: I mean, I would hate to use anything else, but at the moment it’s not great… and getting new people to start in Ignition at the moment would only steer them away

I just wonder how even you can use 8.1.2 and 8.1.3. Those two versions has suffer for bad performance in designer with dealing with embedded view. The UI is freeze all the time.
Now in 8.1.4rc1 they fix it but now we have this new issue.

Apparently that particular performance issue is in 8.1.0 as well. However, speaking to Travis Cox, they made a breakthrough in significantly increasing the performance of loading embedded views and nested views that will make it into 8.1.5. I’ve been working with him on performance issues we’ve been having at a large customer of ours, and we’ll get to test it out as soon as he gets a build. I really hope that it solves some of these major pain points!

2 Likes

Yep, I have been having this problem with 8.1.4 stable too. Very frustrating. My particular gateway is running on a Server 2019 Standard VM. I’m running the designer on the gateway desktop itself via a Splashtop remote connection. Database is MSSQL running on a separate VM in the same box as the gateway.

Wow, very sorry to hear this. We will look into this immediately.

Worth mentioning I have the same issues on later versions as well. It only crops up when using Perspective as far as I’ve been able to tell. I have an open support ticket on the matter, #15782.

Thanks. Good to know. We will group them together if it makes sense.

2 Likes

I’ve been having a similar issue in the last two days, but I can modify/add components in the designer. I get this popup only when I try to save the project.

image

1 Like

Yep i’m getting this still in 8.1.7 as well. Seems to happen mostly during breaks, but it has happened while i’ve been working as well. I am VPNd into a network to access the Ignition gateway and sometimes my connection drops for a few seconds, which I think is causing my issues. Interested if you’re in the same network situation?

My developing platform is a VM and the gateway is on another server (Azure). I’m not using a VPN since both of the machines are on the same network and I don’t think there are any network issues between these two. I closed my designer (‘Save ad Exit’) got the popup again and fortunately when I reopened the designer the changes I made were saved.

I found that I could just close all of my open views (takes a little while as you have to click close, wait for the timeout popup, but then the view closes), and then once all Views are closed, you can then go File->Open and re-open the same project again. If you don’t close each view first, then you just get the timeout popup and only one opened view closes, then the open action cancels itself.

I’m in a same pc for both gateway and designer and have this problem.

I’m seeing the exact same error in 8.1.7 as well requiring a restart of the designer (when editing Perspective views only). Gateway running on local network VM and database on separate VM.

Observation - The timeout exception error as described by others above appears to only happen when multiple views are opened at the same time. If I make sure to close a view I’m editing before opening another view everything appears to be okay. I did this for a days worth of work and never had any crashes. Once multiple views are open and I switch back and forth editing them, that’s when the timeout exception occurs randomly.

1 Like