[BUG-9263] Designer Launcher Fails to Launch

I wanted to add that I am seeing this same issue in the Vision Client Launcher. I have tried version 8.1.35 and 8.1.37. This happening on multiple PCs at our organization and not limited to a single PC. The only information I can find that explains the error is in the windows event log.

Faulting application name: VisionClientLauncher.exe, version:, time stamp: 0x65b92226
Faulting module name: msvcrt.dll, version: 7.0.19041.3636, time stamp: 0x7e27562f
Exception code: 0xc0000409
Fault offset: 0x00086870
Faulting process id: 0x532c
Faulting application start time: 0x01da6a7c72e898a0
Faulting application path: C:\Users\jminton\AppData\Roaming\Inductive Automation\Vision Client Launcher\VisionClientLauncher.exe
Faulting module path: C:\WINDOWS\System32\msvcrt.dll
Report Id: f27f2f34-ade3-43b4-a243-260776d23890
Faulting package full name: 
Faulting package-relative application ID: 

This is being tracked and actively investigated.

Not sure there's any real idea what's going on yet, aside from it may be related to older versions of msvcrt.dll, and/or Windows not being past some certain update that would provide this.

It's unclear right now, but people are looking at it.

1 Like

Same issue here. Not only designer, but Vision client too.

I tested different versions and starting on 8.1.33, the problem occurs. Looking over the release notes for that version, I'm guessing the Java version could be an issue (The bundled version of Java has been upgraded to Java 17.0.8.)

Have there been any updates to this? I'm using 8.1.36

Still open, I don't have any additional details.

@jcoffman anything from Azul on this?

Nothing meaningful yet, Support and I are each working on reproducing this to get some details to Azul. The main issue here is that an error hs_err file is not generated, making this a bit tough to track down and it only happens in some environments. Support is working with reporters to help identify the conditions on this issue.

If you are experiencing this and haven't reached out to support, please do so to provide more information around the problem to help us hunt down the cause!


Greetings Forum, any update on this issue? I have version 8.1.36 on Windows Server 2022, and I cannot open the designer application through the launcher, the error observed is the following, this occurred suddenly after restoring a backup of an existing project on another server. In the launcher log designerlauncher.log, I can see what is shown below. Please, if you have any way to resolve this issue, I would appreciate it.

This thread is about a different issue than you are having.

Looks more like these:

Which have to do with network access blocking the revocation checks.

Thanks Kevin, I appreciate your help, I will try what you mentioned.

Any updates on this bug?

There is a potential fix in the works that has to be tested. Are you experiencing this currently?

For anyone in this thread experiencing the initial issue of the Designer Launcher or Vision Client Launcher EXEs not opening at all, would you be up to test a one-off build of the launchers to confirm the fix? Local reproduction is elusive on this issue and Id like to gather as much data as possible about this fix.

I have a support ticket in and was sent a modified launcher. I was then told the issue I'm having is a different bug (java file not present when launching). I tried manually putting the file in the location but it's cleared away on launch.

Are you describing the issue in this thread?

I replied as there as well, but this doesn't sound like a bug, it sounds like a problem with AV/security software.

1 Like

I can try, I`m still facing the issue. I have just downloaded 8.1.42, but no good.
Please reach out, if you still need someone to test.