[BUG] blank tag group

ignition80
#1

Ignition 8.0.4-NIGHTLY - 21/08/2019

@awalker, could you please fill a ticket for this bug :

After some 7.9 scan class import, Tag group Default and Default Historical are blank

0 Likes

[BUG-12289] Possible to import Tag Groups
#2

Can you provide both your 7.9 scan class import file and an export of your 8.0 tag groups (before import of the 7.9 file)? We need to try to replicate what you are seeing.

0 Likes

#3

Hi @mgross

I don’t have the tag groups before the import.I can only provide you the export
scanclasses7.9.csv (3.0 KB)
tag-groups.json (11.6 KB)

As a side note,
I’ve tried to create another realtime provider named “test” to test scan class and tag import, but when I’ve created this new provider, the data are mixed in the designer between this new provider and other managed tag provider…

Before
image

Create another realtime provider : “test”

image

tags of the managed provider “replay” are displayed both in “replay” provider and the new “test” created !

0 Likes

#4

Yeah, I don’t have any good answers today. I did notice that your 8.0 tag group export json contained {} at the top, but I cannot provide any explanation of how it got there. After I removed the empty entry, I did not have any problems with importing the default tag group. The 7.9 scanclasses csv also worked without issues. Whatever happened must have happened the first time you imported 7.9 scanclasses. I also created several new realtime providers, and I can’t see any duplicated tags between providers. Without being able to reproduce what you saw, we are kind of stuck.

0 Likes