[BUG] Extension functions ( Power Table from Igntion 7.9.10) not working

The behavior you unexpectedly encountered : I can’t type any code inside the initialize extension functions ( Power Table ). I tried other extension functions, but none of them works. NB: The project I’m working on has been imported from Igntion 7.9.10. If I create a new power table, I can code inside the extension functions section.

The behavior you were expecting to see : I was expecting to be able to write code

A list of the steps you took that exposed the issue:

  • right-click on the power table
  • scripting
  • enable initialize
  • can’t write anything

A list of helpful information about the situation you were in:
Ignition 8.0.4 STABLE

Hi c.bertulli

I followed the steps you provided below and was not able to reproduce the issue.

I was wondering it you are able to use the extension functions in the power table when you restore a gateway backup or upgrade from 7.9 to 8.0.4?


The project I’m working on has been automatically converted to Ignition 8.0.4 from Ignition 7.9.10 when I upgraded the gateway.

Hi c.bertulli,

Is it now working correctly?


Well, I deleted the component ( coming from Ignition 7.9.10 ) and redo it ( in Ignition 8.0.4 ) and it worked.

Happy to know it is working