BUG Icons don't render unless in SSL on Chrome

Viewing a Perspective project in Chrome, without SSL (port 8088), Material Icons (at least) do not render (are invisible) unless you use ‘localhost’ as the address. If you enter the real IP address, even FROM the server machine, you will not get the material icons.

You can get them to work with non-localhost URL only if you use SSL URL.

Does not seem to be an issue using Edge browser.

I’m having the same issue. We have a system that was on 8.01 (RC2 I think) and the icons were fine. I installed 8.03 to get some of the fixes and the icons disappeared in Chrome browser.

The symptoms seem to be identical to what you’re experiencing.

We can verify this is true with 8.0.4 as well. Works in Edge - not in Chrome.

I am attempting to replicate this issue and have not been able to successfully. A few questions I have:

  1. Which version of Chrome are you working with?
  2. Are you using the stock SSL certificate that came with Ignition, or one that is signed by a CA?
  3. Is there a specific component you are seeing this issue with? We are testing with the Icon component based on the description, but wanted to confirm.
  4. Are there any console errors when this issue occurs? This can be checked by right clicking in the browser, selecting Inspect from the menu, and clicking on the Console tab
  5. Does this issue occur when the browser is in Incognito mode?
  6. Does your Gateway have any non-standard networking devices (e.g. a load balancer) or software (e.g. nginx) in front of it?


Hi Garth,

Version 77.0.3865.120 (Official Build) (64-bit)
We aren’t using SSL but we also didnt add our own.
There are no console errors.
Yes this issue occurs in incognito mode.
No there are no network devices between our client and the server.

I’m going to work on creating a single window with a single icon on it and send you the window export along with screen shots from both browsers.

Hi Garth,

Am a colleague of plarochelle. Please see below for snapshots of Edge/Chrome Windows. Same view/window, different browsers.


Also, see attached for a copy of a test project:TESTING_2019-10-15_1445.zip (4.9 KB)

@azoraian, thank you for the additional information. I am still unable to replicate this issue internally. The project provided was exactly the same thing I was attempting when originally attempting to reproduce. From the screenshots, it looks like the icon does have a header and left dock as well. I have attempted to reproduce with different variations of these components added to the provided view as well without any luck.

In the original post, the author mentioned that localhost instead of the IP worked as expected. Is this true in your case? Is the issue only an issue on a single computer (like only on the server running Ignition) or does it happen with any Chrome browser connecting to the View?


Hi Garth,

I managed to test the connection via localhost in place of the gateway IP address,. and as the author stated, this works. Unfortunately, this issue is not local to a single computer; connecting via IP address from any of the computers on our network using Chrome causes icons to not appear.

Is your company using Google Enterprise by any chance to force settings for Chrome? If so, do you know what settings they are using? On the Gateway, are there multiple NICs with an IP on a different subnet that could be tried?


We are not using Google Enterprise, and the gateway is only on one subnet.

I have tried everything I can think of and cannot replicate this issue internally. At this point I would recommend talking with support as there is something specific with the network setup that is likely causing this issue that needs to be understood on our side.