[BUG] iOS App Dropdown Not Selecting

I’m trying to use the dropdown component in an iOS phone application and am having difficulties selecting any of the options. I’ve tried it on a couple of different phones but am still seeing the issue. The search function doesn’t show filtered options when typing, and selecting any of the options just closes the dropdown.

My dropdowns seem to be working as expected on iOS. Could you send a copy of your View?

I have experienced the same thing, It appears that the dropdown selection does not work unless you click directly on the text itself. if the bar is much larger then the option you are selecting it acts in a sparatic way.

Additionally, I find that if you scroll page while the dropdown is open still and try and select an option there it will select the item that “use to be” in the position when the sropdown was first interacted with.

I have not experienced this while using iOS. and just tried with a dropdown which spanned the width of an iPad Pro. What sort of device were you using, and what version of iOS?

Are you encountering this with iOS? You should not be able to scroll while a dropdown has its options expanded. If you’re able to, please let us know so that we can investigate - otherwise I’ll assume you meant you encountered this while using something other than a mobile device.

I have experienced this on IOS. Ipad 9.7" and Ipad mini.

I will DM you some screen recordings if you would like?

I’m using an iPhone 7.

Since I was unable t replicate the behavior I turned this over to a Dev. He’ll be investigating it further. Are you using the latest build? He seems to think we had a fix for this go in sometime over the last couple of days.

Well I just updated to last night’s build and the project I was using is now not showing up as a perspective project. I can open it in the designer and when I hover over my views I can see them on the mouseover, but when I try to open them up I get “no-project” on the view editor. So I can’t test this functionality…

Hi Christopher,

We still weren’t able to replicate this on our end. If you are still seeing this issue, please let us know.

This seems to work after loading a recent nightly build.

1 Like