Bug on dropdown in editable selection mode

Even in editable selection mode it is not possible to write into the dropdown. It behaves like in lenient mode if when writing a partial match is found with one entry of the dropdown. The version of Ignition Platform is: 8.1.2. I just notice it was working fine into the previous version ( but im not sure anymore which one sine i have upgrade my ignition several time without checking the dropdown behaviour)

Any chance you could provide a concrete example of the behavior you’re seeing versus what you expect to see?

Hi @cmallonee

Current Behavior

right now i don’t have the possibility to freely write in the editable dropdow( what i could do before). When writting, as soon as a partial match is found with one entry of the dropdown this entry is selected, and a the end ot that selectedStringValue some of the chars i was typing in are appended. The only way to freely write into the dropdown is when no match( or partial match) is found with an entry of the dropdown. This behaviour looks more like the one in linient mode than what the editable mode should be.

Expected Behavior

What i expected in this mode is to be able to write what ever i want in to the dropdown. Then i could for instance react to the keyrelease event with keyCode == 10 And from there decide what to do. I could do a check against the datasource of the dropdown to see if the given text is found. I could then either display a message saying that no match is found or add the given text to the dropdown.

Example
The following dataset is the datasource of the dropdown box in editable mode:

P.Number(string) || Label(string)
123 … … … … …123 | First
136… … … … …136 | Second

so i write 123, the dropdown will display 123 | First3
if i write 136, the dropdown will display 136 |Second6
There is no way i could write for instance 126. Because 12 will be a partial match with 123. consequence 123 |First6 will be displayed.
What i expect is to be able to write 126 or even 123, then react to the enter key to decide what to do with that given text if is not in the datasource. If i am don’t make a mistake, in the previous version where it worked, the selectedLabel event where trigger only after enter was pressed. so i could react on it to do my check. Now it is triggered everytime you press a key (This is probabily why the partial match occurs and an entry of the datasource is selected before i end typing in what i really want)

I hope you will be able to understand the problem with this description of mine.
Best regard. :grinning:

1 Like

Hi,

I am having the same issue:

Users start typing something new (ie, not in available options) in the editable dropdown, and as soon as a key matches the first key of any of the available options, this option will overwritte what the user had written.

Thanks :slightly_smiling_face:

@eric.petke and @francisco.carmona : could you please send me the following:

  1. The view.json file of the view in which you are encountering this issue.
  2. If the options of the dropdown are bound against some sort of value, please send me static data so that the dropdown will function.
  3. A concise description of the steps to encounter this issue using the data currently in the dropdown I will be using. I need to know exactly what text you are supplying character-by-character so that I can replicate this on my end. For example: Supply "123" to see that "123 | First3" has been entered as a custom option.

Thanks for your answer, @cmallonee.

Drodown component:
Dropdown.xml (1.7 KB)

Data is static:
image

Description:

  1. Open the dropdown (whose ‘selection mode’ is set to ’
    editable’) and clear its content (’<Select One>’)
    image
  2. Type ‘Three’, and as soon as ‘T’ is typed, row 3 with ‘Third Item’ is selected. In the end I see:
    image

In case it were any use, the properties:

Thanks
Francisco

Oh, so this is for the Vision dropdown? I’d been trying to replicate the issue with a Perspective dropdown.

1 Like

Yes, my bad it it was not clear. I am seeing the issue in the Vision dropdown.

Thanks

No you were clear: you put “vision” in the topic tags. @cmallonee just missed it. Happens.

Whoops, no, you didn’t. ):

It is one of my first posts, so I’m not quite sure where topic tags show. But, below the title “Bug on dropdown in editable selection mode” I see “Ignition” and “vision”.

Let me please know if we need to ask the question somewhere else.

Thanks

You weren’t the OP. Eric didn’t tag the topic with “vision”, @cmallonee used his admin privileges to do so. The question was ambiguous until until your screenshot showed the “Vision Property Editor”.

Don’t worry about it. This is the right place to post.

Yes my bad. i should have precise that it is a Vision issue. Sorry for the inconvenience.

I’m having the same issues on multiple dropdown components across multiple windows (VISION) on 8.1.5. Has this issue been addressed / resolved? Users are having to type in a different field, then copy & paste that entry into the dropdown component. :man_facepalming:

Can anyone with experiencing this try a recent 8.1.8 nightly build? There’s some changes made around the new look and feel that may affect this.

I created a test window on the latest nightly build (8.1.8-SNAPSHOT.20210614-0851) and have the exact same issue. As you can see in the screenshot below, I created a dropdown menu with manually-populated entries and set type to “editable”. In run mode, I clicked in the box and typed the letter “P”. It immediately selected “Pontiac” and then also typed the letter “P”.
image
If I continue typing “o” the selected dropdown item updates to “Oldsmobileo”, having seemingly forgotten that I typed “P” and instead matching the first entry beginning with “o” and tacking an extra “o” onto the end of said entry.
image

@BFischer in my case since typing in the value was just for fast selection (No unknowed value was allowed) ,i have changed the dropdown selection mode from Editable to lenient So the user can type in what it is looking for and the that value will be selected if available. But he need to type in without pause. And if he anyway he had to stop before the end of his typing, he will just have to start typing from the start of the word again.

@eric.petke In my case, the user needs to populate a “Manufacturer” field and needs the ability to input new values. This worked fine back in 7.9.x, but after upgrading to 8.1, it’s been a problem on several entry pages. I’m sure it’s a small bug inadvertently introduced, but it’s still disappointing to see it hasn’t been resolved yet. I’m thinking about adding a button for “New Entry” and overlaying an input box on top of the dropdown menu. Messy, but it may be the quick workaround I need to implement while I wait for IA’s fix.

Good afternon, I’ve the same issue in the 8.1.6 versione.

Anyone know how to write a text without this problem?