Bug report Interpolation Mode reads incorrectly depending on tagpath value

#1

I have tested with Ignition 7.9.7 AND 8.03 so I will report it for version 8

Behavior:
imode = system.tag.read(atag+".InterpolationMode").getValue() returns different answers depending on the tagpath (for the same tag).

Expected:
Full or partial path should give same result, but the partial path is the one that gives the correct result.
example:
full tag path:
histprov:process:/drv:ignition-sctest:default:/tag:testing/simulator/realistic0
partial path:
testing/simulator/realistic0
both return same trend data, but the full path returns InterpolationMode as None
and the partial path returns InterpolationMode as Discrete when using system.tag.read as noted above.

I am writing this from home so I don’t have the database version, but it is Mariadb, fairly recent version.

OS is Ubuntu 18,04 for the test with Ignition 8

OS is Ubuntu 16.04 for the test with Ignition 7.9.7 and the database here is MSSQL 2014

One additional note is that Ignition 7.9.7 returns 0 or 3
while Ignition 8.0.3 returns Discrete or None.

To setup for the test, Install Ignition 8.0.3, and a database, and create a database named process.
set the default history provider to be the process database
create a history tag, save it. then go back and change it to have (old terminology = InterpolationMode (Value Mode)) of Discrete. I think the terminology in 8.0.3 is something different like Deadband Style, but the InterpolationMode property gives the same result.

Why does it matter: I use the InterpolationMode to process the data differently depending on the value. I normally get the tagpath from the tag browser which returns the full path, which does not work correctly for this purpose.

0 Likes