[Bug-Resolved] commented out value still errors in script

  1. List item

When I go to the custom property for the root container in perspective, I ave commented out other attempts, but I still get an error in the wrapper log…

  1. List item
    Not expecting to have an error in the wrapper log for something commented out…

  2. List item
    To expose this I was watching in the wrapper log and kept seeing the “line 3” error that object has no attribute ‘scanBarcode’. Deleting the # commented out rows or putting them in triple quotes seems to resolve this…

Potentially not a bug? Syntax for commenting out in Perspective needs the triple quote instead?

Is this still happening? Perhaps you could export the view in question and attach it here.

I was seeing this on multiple views, anytime a hash tag comment (or ctrl+/) was used.

Although I can still attach a .JSON if you would like

A JSON for the View would be helpful, as I’m not able to replicate this with the following setup:

In attempting to duplicate, I am unable to have it throw the same error… so I am guessing it must have been fixed with one of the nightly builds since I had this issue

Or perhaps the script wasn’t saved after the comments were put in place? Either way, I’ll close this thread for now. If you encounter it again, please let us know.