[Bug-Resolved] No Designer button in browser, no gateway in designer launcher

The behavior you unexpectedly encountered -
No designer launch button in gateway browser
No Gateway connection when trying to launch through the designerlauncher.exe

The behavior you were expecting to see -
The designer to open

A list of the steps you took that exposed the issue - including your starting point.
-Doubleclick or otherwise open designerlauncher.exe
– click the ‘Add designer button’
— under the select a gateway screen, other gateways on the network “blink” into existence on the designerlauncher.exe then disappear.
— when I click the manually add gateway button, the window pops up for the http://host:port but the gateway URL is invalid and the button is never clickable.
-(No launch button to click in browser to try)
-Following the “[BUG] Designer is never actually launched” thread also.
-changed designerlauncher.exe logging level to trace (just shows my path and tells me to look here for future logging events)

A list of helpful information about the situation you were in, such as:
Ignition 8.0.0-beta1
Client and gateway java is build 1.8.0_191
Win10

Update: I used the IP for connection, although in a DHCP climate, that won’t fly.

Hi @brian.mills,

I am looking into the issues you describe. I believe I know what your issue is in the manually add gateway dialog and will have a fix in soon for it. Just to be sure, what is the address you are using the add gateway dialog?

Thanks,
Jonathan C

I was using a host name to attempt connection, but tried IP address and it worked. (PRO-MA-WD0098:8088 vs IP:8088)

1 Like