[BUG] Table column width not being respected

I have a Perspective table with columns having width and strictWidth properties set. In the designer it appears how I want it to, but in the browser it isn’t respecting the width setting.

Designer:

image

Browser:

image

Hi,

What browser is your Perspective client session using?

-Yousuf

The latest version of Google Chrome

That’s very odd. Are you able to replicate this with the example data? If so, what are the steps?

-Yousuf

Well uh.

I dunno why this fixed it, but I added the sample data table and set it up how I had the other one, and I couldn’t reproduce it.

Then I got rid of the old table and replaced the sample data with the data I need, and it’s working fine now.

No clue why it stopped happening, but I’ll mark it as solved and post again if the issue comes up and I’m better able to isolate what’s causing it.

Thanks for the help!

That’s a head scratcher. Glad it worked. Let me know if it happens again. -Yousuf

1 Like

I am now experiencing this issue in 8.1.0. Whenever I launch preview mode in the designer, the columns of the table snap to flex, ignoring the strict width I’ve set.

Any updates? Also experiencing this issue. Have an expression structure and transform generating a dataset, but the table in the browser and in preview mode aren’t respecting the width property.

I would also like a follow up on this issue as well if possible. I am experiencing a similar problem.

I am seeing a similar issue, but it seems to stem from the opening and closing of a subview. I have multiple tables, some of which are setup very very similarly and not all of them exhibit this behavior but it is repeatable for given ones. Every time the sub view is opened it appears the columns add a little to the width (causing a lot of word wrap on the far right column). When I close the subview they again have some width added. This is happening on columns that are set to strictWidth as well as those that are not. I first started noticing this on 8.1.9 (I think we had been on 8.1.7 w/o issue).