[BUG?] Tag History binding not pulling in data properly?


I’m seeing some strange behaviour with a tag history binding. I have the following binding config:

With these dates configured, I get data returned:
Start / End

Data returned:

When I add 1 minute to start datetime, I get no data returned:

Data returned:

This same arrangement worked in previous versions?

Haven’t tested, I just plonked some components onto a View to test something and found this odd behaviour

how did you get the initial dates? can you check if both are the same type.
ive had it that i pull dates from sql and it gets seen as timestamp, the datepicker recognizes it as a date, but the code things its a long int sometimes. and when you pick it from the datepicker it changes into a java.util.date

The dates in the dates pickers were set manually by me via the component calendar popups, so they should be properly set as date times. And I can literally use the time spinner to decrease the time by a minute and the data is pulled in

does it work with different times? or is only 21.35 that doesnt work? does 21.30 work?

It seems to not work >= 21:35, despite there being data all the way up to the end date time…

what if you change the date of max range by one day? and then try to get 21:35+ on min date.
so21-08-25 24:40 to 21-08-27:1800

Yep, tried all that as well. Anything before 2021-08-25 21:35 displays data. Anything after it doesn’t :confused:

how about the day before but that hour 2021-07-25 21:35 ?

I think you’re getting sidetracked… the issue remains regardless of what else works and what else doesn’t. I’m not sure trying other date combinations will help to narrow down the issue further (not to mention it could also take a significant amount of time to test, and at what point do you stop?)

I wonder if it’s worth trying queryTagHistory, system.tag.queryTagHistory - Ignition User Manual 8.1 - Ignition Documentation. If that works then it points to something in the component?