[BUG]Template UDT Instances Stopped working until Gateway Restart


In version 8.0.7 we just encountered a weird situation. For some reason a select group of UDT template instances were not working. The tags were being communicated with fine as we can see them update in the tag browser, but the template refused to update based on the tag status. The same template is being used everywhere else and was working fine elsewhere except this aforementioned group.

However once we restarted the gateway these template instances worked as normal. Anyone know what could’ve caused these template instances to stop working in the first place?


I’m bumping this thread because we just encountered this again. This time we had 4 of the same template instances on the same screen, 3 of them were displaying correctly while the 4th one was not updating despite the tags being read correctly in the tag browser.

We see something like this happen (also in 8.0.7) after accepting an update in clients. Navigating to a different page and then back to the original page seems to clear it in this case.

Interesting. We tried restarting the client and designer but the template instances were still not updating. Only after a gateway reset did the instances work.