Button background color scripting name

In the manual and the mouseover text the scripting name of the button component background color is ‘buttonBG’ it is actually ‘background’

Ignition 7.8.2

Yes, the manual needs to be corrected, unfortunately, it’s not a simple correction.

The correct thing to use is actually getButtonBG(), not the .background property or the getBackground() function. (And if you’re setting the background color, use setButtonBG(Color c) ). The reason you should use getButtonBG() is that we do some extra checks and type conversions that are needed because of some oddities in the Java look-and-feel that we use. Unfortunately, it looks like the auto generation on the docs see these getters and setters and assume there’s a property by the name of .buttonBG, which isn’t the case.

In general, on all components it’s better to use the getters and setters than to manipulate properties directly.