Caching_sha2_password

Has anyone else had the following problem when connecting Ignition to MySQL8.0.4?

Cannot create PoolableConnectionFactory (Unable to load authentication plugin ‘caching_sha2_password’.)

Has anyone managed to get Ignition to connect and if so how? I am unable to change the user authentication from caching_sha2_password.

At the very least you have to install a newer JDBC driver for MySQL 8. I’m not sure if there’s anything else needed.

1 Like

Copied from another forum but I had the same issue and this fixed it. I found this with the same error, when trying to remove sha2 from the user profile in the workbench it would enable it straight away when I applied the changes. Once I did the below in the preferences I was then able to remove sha2 In workbench and apply it. Then ignition connected to it.

Open MySQL from System Preferences > Initialize Database >
Type your new password.
Choose ‘Use legacy password’
Start the Server again.
Now connect the MySQL Workbench

1 Like

Thank you.

I did that and it came up with a different error message that I managed to resolve by updating the drive to mysql-connector-java-5.1.46.

I had the same issue and the following article resolved the problem.

https://support.inductiveautomation.com/index.php?/Knowledgebase/Article/View/125/0/connection-errors-when-configuring-mysql-80-database-in-ignition

2 Likes