Calling Custom method not longer working

I have a 7.9.12 project, it is using SHARED called between the client pictures and the Script Library located inside the GLOBAL

I have references from certain button from the picture as follow

where ICI_USER is the name of the library has it appears in the system tree, my_method is the name of the method defined inside the ICI_USER as follow Def my_method(param1, param2):

When clicking on the picture push button it does invoke the my_method perfectly on multiple computer, except one. on that one, where the project was restored, I get an error message indicating that my_method does not exist.

Similarly, the same picture contains calls to method that are nested inside object and the call looks like

where MAIN is the object where the method is located, leavemain is the method

on the same exact computer the same calls are not working either same error pops up indicating that the method does not exist

as said this is working perfectly on other machines I restored the project and I cannot find the reason why the calls would not work on one and only one machine which has the same exact version of ignition than the other one. none of the machine are connected to each other, the project are standalone project

more interestingly, the machine on which the project is no longer working was working perfectly until…until I don’t know what but something changed. I hate the obvious it used to work but it is not working anymore but it is what is happening…any idea ?


I have run into this in the past and I am unable to explain why. Phil Turmel has given explanations about this so you can search his posts. As in interim solution I tried renaming the shared.{name} to another name and it worked, although, I am not sure why. Since then I have been using external packages and it has been working fine. I hope this helps.